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OrCAD User’s Guide 
 

Section 1. Introduction to OrCAD 
1. An overview. 
 

OrCAD offers a total solution for your core design tasks: schematic- and VHDL-
based design entry; FPGA and CPLD design synthesis; digital, analog, and mixed-signal 
simulation; and printed circuit board layout. What’s more, OrCAD’s products are a suite 
of applications built around an engineer's design flow—not just a collection of 
independently developed point tools. 

Capture is a versatile design entry product you can use to create schematics for analog 
or mixed signal designs, printed circuit board layout designs, and programmable logic 
designs. First, create your flat or hierarchical design in the schematic page editor, then 
use Capture’s tools to quickly annotate it and prepare it for the next stage of 
development. 

Orcad Component Information System (CIS) is just one element in our total solution 
design flow. Orcad CIS is a part management system that is available as an option for use 
with Orcad Capture. Orcad CIS helps you manage part properties (including part 
information required at each step in the printed circuit board design process, from 
implementation through manufacturing) within your schematic designs. 

 
2. Typical printed circuit board design flow. 
 

Typical board design tasks include the following: 
1. Creating the board. Using Capture, you create a netlist from your schematic that 

may include your design rules to guide logical placement and routing, then load the 
netlist into Layout. 

2. Specifying board parameters. You specify global settings for the board, including 
units of measurement, grids, and spacing. In addition, you create a board outline and 
define the layer stack, padstacks, and vias. 

3. Placing components and checking the placement. You use the component tool to 
manually place components on the board individually or in groups. You then check the 
placement using placement information from a variety of sources. 

4. Routing the board and checking the routing. You route the board, and can take 
advantage of push-and-shove (a routing technology), which moves tracks to make room 
for the track you are currently routing. You then check the routing using routing 
information from a variety of sources. 

5. Finishing the board. Layout supplies an ordered progression of commands on the 
Auto menu for finishing your design. These commands include Design Rule Check, 
Cleanup Design, Rename Components, Back Annotate, Run Post Processor, and Create 
Reports. 
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Figure 1. PCB design flow. 

 
3. Files we may be working with. 
 

A netlist file (.MNL) describes the interconnections of a schematic design using the 
names of the nets, components, and pins. A netlist contains the following: 
! Footprint names 
! Electrical packaging 
! Component names 
! Net names 
! The component pin for each net 
! Net, pin, and component property information 
A technology template (.TCH) specifies the characteristics of a board, including 

manufacturing complexity and component type. Technology templates can also include 
the layer structure, grid settings, spacing instructions, and a variety of other board 
criteria.  

Technology templates have a .TCH extension, and enable you to set design standards 
for your boards quickly and easily. It may be easiest to think of a technology template as 
a board without physical objects or net information. 

When you load a technology template, it replaces certain settings in the board, and 
ignores others. It replaces the following information: 
! Placement strategy 
! Routing strategy 
! Number of defined layers, layer names, layer properties (such as spacing) 
! Grids 
! Padstacks 
! The following information is ignored when you load a technology template: 
! Colors 
! Packages 
! Symbols 
! Components 
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! Nets 
! Connections 
! Obstacles 
! Text 
! Everything else 

DEFAULT.TCH 
Default technology template for typical boards. Based on Level A as described above, 

a standard DIP IC pin has 62-mil pads and 38-mil drills. Routing and via grids are 25 
mils, the placement grid is 100 mils, and route spacing is 12 mils. 

A board template (.TPL) combines a board outline and possible mounting holes, edge 
connectors, and other physical board objects merged with Layout’s default technology 
template, DEFAULT.TCH.  

A board file (.MAX) contains all of the board’s physical and electrical information. 
 

Section 2. Introduction to Capture 
 

1.To start Capture 
 

1) From the Start menu, point to Programs and choose Orcad Family Release. 
2) From the Orcad Family Release menu item, choose Capture. 
Once you start Capture, you see the Capture session frame. You do all your schematic 

design and processing within this window. 
Depending on which type of window you have active (an active window is one whose 

title bar is highlighted), certain buttons on the toolbar and certain items on the menus may 
be unavailable, since you perform tasks and use tools based upon the type of window that 
is active. 

Also, the menus and menu choices vary, depending on which type of window is 
active. The available menus and menu choices also vary depending upon the type of 
project. 

 
2.The Capture work environment 
 

The project manager 
You use the project manager to collect and organize all the resources you need for 

your project. 
The schematic page editor 
In the schematic page editor, you can display and edit schematic pages. You can place 

parts, wires, buses, and draw graphics. The schematic page editor has a tool palette that 
you can use to draw and place everything you need to create a schematic page. You can 
print from within the schematic page editor, or from the project manager window. 

The part editor 
Create and edit parts using the part editor. 
The session log 
The session log lists the events that have occurred during the current Capture session, 

including messages resulting from using Capture’s tools. To display context-sensitive 
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help for an error message, put the cursor in the error message line in the session log and 
press F1 . 

The toolbar 
Capture’s toolbar is dockable (that is, you can select an area between buttons and 

drag the toolbar to a new location) and resizable. By choosing a tool button, you can 
quickly perform a task. If a tool button is dimmed, you can’t perform that task in the 
current situation. 

The tool palettes 
Capture has two tool palettes: one for the schematic page editor and one for the part 

editor. Both tool palettes are dockable (that is, you can click on an area between buttons 
and drag a tool palette to a new location) and resizable. 

The status bar 
The status bar, located at the bottom of the Capture session frame, reports on current 

actions, number of items selected, zoom scale, and pointer location. 
 

3.Creating new projects, designs, libraries, and VHDL files 
 

Creating a project does not create a design within the project. A new design inherits 
characteristics from the settings in the Design Template dialog box, so you should always 
check those settings before you create a design. 

To create a new project: 
1) From the File menu, choose New, then choose Project. The New Project dialog 

box appears. 
2) Type a name for your new project in the Name text box. 
3) Use the Browse button to select a new directory. 
4) Select a project type in the Create a New Project Using group box, and click OK. 
Capture provides the following project types: 
! Analog or mixed signal circuit—select this type of project if you intend to use 

your design with PSpice. Follow the guidance of the Analog Mixed-Mode Project 
wizard to add the appropriate files to your project. 

! PC board—select this type of project if you intend to use your design with Orcad 
Layout. Follow the guidance of the PCB Project Wizard to add the appropriate 
files to your project. 

! Programmable logic—select this type of project if you intend to use your design 
with an FPGA or CPLD EDA tool. Follow the guidance of the Programmable 
Logic Project Wizard to add the appropriate files to your project. 

! Schematic—select this type of project if none of the other project types apply. 
Using this option, Capture creates a basic project containing only the design file. 

Creating a new design 
1) From the File menu, choose New, then choose Design. 
2) The design opens in a new PCB project manager and a new schematic page 

displays. 
The first time you save a new design, the Save As dialog box appears, giving you the 

opportunity to specify a drive and replace the system-generated name. 
Creating a new schematic page 
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1) On the File tab of the project manager, select the schematic folder that requires a 
new schematic page. 

2) Click the right mouse button and choose New Page from the pop-up menu. A new 
schematic page appears within the schematic folder you selected in step 1. 

Creating a new library 
1) From the File menu, choose New, then choose Library. 
2) The library opens in the project manager and a Library Cache folder is added to the 

project manager, or the library opens in the existing open project manager and a library 
cache is added. 

Opening existing projects, designs, libraries, and VHDL files 
You can open an existing project, design, library or VHDL file. Existing schematic 

pages can only be opened from within designs and libraries. 
Setting up your project 
Capture provides different levels of configuration. Using commands on the Options 

menu, you can: 
! Customize the working environment specific to your system (using Preferences). 
! Create default settings for new designs (using Design Template). These settings 

stay with the design as design properties even if it is moved to another system 
with different preferences. 

! Override settings in individual designs (using Design Properties) or individual 
schematic pages (using Schematic Page Properties). 

The settings in the Preferences dialog box determine how Capture works on your 
system, and persist from one Capture session to the next because they are stored in the 
Capture initialization (.INI) file on your system. If you pass projects to others, they won’t 
inherit your Preferences settings. This means you can set colors, grid display options, pan 
and zoom options, and so on to your liking and be assured that your settings will remain, 
even if you work on a project created on another system. 

The Design Template dialog box determines the default characteristics of all the 
projects created on your system. Because a new project inherits characteristics from the 
current Design Template settings, it’s a good idea to check the settings before you create 
a new project. 

Once you begin working on a project, you can customize its particular characteristics 
by choosing Design Properties from the Options menu when you are in the project  
manager, or Schematic Page Properties when you are in the schematic page editor. 

Changing properties of existing projects 
When you create a new project, it uses the options defined in the Design Template 

dialog box. You can set the options on existing projects using the Design Properties 
dialog box (from the project manager’s Options menu). The options are: 
! Fonts. You can define the fonts for schematic page objects that contain text, such 

as part references and part values. 
! Hierarchy. You can specify hierarchical blocks and part instances whose 

Primitive property is set to Default be treated as primitive (cannot descend into 
attached schematic folders) or nonprimitive (can descend into attached schematic 
folders). 

! SDT Compatibility. You can specify which Capture properties map to which SDT 
part fields when saving the design in SDT format. 
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! Miscellaneous. You can view the project name, root schematic folder name, 
creation time, and modification time. Also, if you need to see the power pins on a 
schematic page for documentation or debugging purposes, you can display them 
on the screen. 

Changing properties of existing schematic pages 
When you add a new schematic page, the options defined in the Design Template 

dialog box are used. You can override these options on existing schematic pages by using 
the options in the Schematic Page Properties dialog box. You access this dialog box by 
choosing Schematic Page Properties from the schematic page editor’s Options menu. The 
options in the Schematic Page Properties dialog box are: 
! Page Size. You can specify the unit of measure and the page size. 
! Grid Reference. You can set the number of horizontal or vertical border grid 

references to display, whether the grid references are alphabetic or numeric, 
whether they increment or decrement across the schematic page, and how wide 
the grid reference cells are. You can also make the border, grid references, and 
title block visible or invisible. 

! Miscellaneous. You can view information about the schematic page, such as 
creation time, modification time, and page number. 

Design structure 
Capture offers two ways of handling multiple-page designs: a flat design structure 

and a hierarchical design structure. 
In our case, a flat design is sufficient for our relatively simple circuit. 
A flat design is a structure in which the output nets of one schematic page connect 

laterally to the input nets of another schematic page in the same schematic folder through 
objects called off-page connectors. 

A flat design has no hierarchy. 
 

4.Placing, editing, and connecting parts and symbols 
 

Capture includes libraries containing parts, power symbols, and ground symbols. You 
can place instances of these objects on a schematic page. Once you place a part, you can 
edit its appearance, properties, or location. Once you have placed a power or ground 
symbol, you can rotate it or edit its name. 

Capture libraries also include symbols used to establish connectivity between 
schematic pages. You use off-page connectors to connect signals between schematic 
pages within a schematic folder. 

Wires and buses are used to conduct signals between parts and electrical objects. Nets 
are made up of one or more wires; a bus represents multiple signals or nets. 

Libraries 
Libraries are files that contain reusable part data. They contain parts that you can 

place as instances on schematic pages. Libraries contain a variety of symbols (such as 
power symbols, ground symbols, and so on) and title blocks that you can reuse in your 
projects. 

The relationship between the library and the parts and symbols it contains is similar to 
the relationship between a schematic folder and its contents. The contents of the library 
move with the library and are deleted with the library. 
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You can create custom libraries to store any combination of items. You can, for 
example, create a library to hold schematic pages that you use often. There is no need to 
create a library for a project, because the design cache holds all the parts and symbols 
used in the design. 

When you work with a library in Capture, you use the project manager. The project 
manager lists the parts and symbols contained in the library. 

To edit a part, double-click on it. The part opens in a part editor window. 
To move a part to a different library, open the source library and the destination 

library in separate project manager windows. Select the part and drag it from one library 
to the other. 

To copy a part to a different library, follow the same procedure but hold the C key 
down while you drag the part. 

Because a library is a file, you can work with it in the Windows Explorer as well as in 
Capture. When you need to back up a library, use Windows Explorer to create a copy. 

Parts 
Parts are the basic building blocks of a design. A part may represent one or more 

physical elements, or it may represent a function, a simulation model, or a text 
description for use by an external application. A part’s behavior is described by a PCB 
footprint, an HDL statement, or an attached schematic folder. 

Parts usually correspond to physical objects—gates, chips, connectors, and so on—
that come in packages of one or more parts. Packages that have more than one part are 
sometimes referred to as multiple-part packages. For simplicity, Capture usually refers to 
both parts and multiple-part packages as parts. 

You can specify packaging information when you create a part, or you can change it 
in the part editor (from the Options menu, choose Package Properties). 

Each part has graphics, pins, and properties that describe it. As you place the parts in 
a package to suit your design requirements, Capture maintains the identity of the single 
physical part—the package—for back annotation, netlisting, bills of materials, and 
processes that require it. 

The parts in a package may have different pin assignments, graphics, and user 
properties. If all the parts in a package are identical except for the pin, the package is 
homogeneous. If the parts in a package have different graphics, numbers of pins, or 
properties, the package is heterogeneous. 

Creating and editing parts 
In Capture you can create parts and add them to a new or existing library. You can 

also edit existing parts in a library or on a schematic page. All of these processes are 
described in this chapter. 

To create or edit a part, you use the part editor. There are many different ways to 
access the part editor: 
! To create a new part, open a new or existing library in the project manager with 

the library selected. From the Design menu, choose the New Part command. 
! To edit an existing part, open a library in the project manager, then double-click 

on the part. 
! To edit a part instance on a schematic page, select it.From the Edit menu, choose 

Part. 
Placing and editing parts 
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A library part has a package view, which corresponds to the actual physical object 
that can be placed, for example, on a printed circuit board. In addition to the package 
view, a library part has a part view, which is a graphical representation used to define a 
single, logical, electrical object whose electrical connectivity is represented by pins. 

Placing parts  
You select parts from libraries and place them on schematic pages using the Part 

command on the Place menu, or using the part tool on the schematic page editor tool 
palette. 

Alternatively, if you’ve placed the part or symbol recently, place the part using the 
Most Recently Used (MRU) list on the Capture toolbar. 

From the schematic page editor’s Place menu, choose Part. 
or 
Choose the part tool on the schematic page editor’s tool palette. 
The Place Part dialog box appears. 
Select a part from the list that appears. 
or 
In the Part text box, type the name of the part. (Valid wildcard characters are an 

asterisk (*) to match multiple characters and a question mark (?) to match a single 
character.) 

When you have located the part you want to place, click OK. 
Move the pointer to the location on your schematic page where you want to place the 

part, then click the left mouse button. You can place multiple instances of the part by 
clicking the left mouse button at each location where you want an instance of the part. 

When you are done placing instances of the selected part, choose End Mode from the 
right mouse button pop-up menu, or press ESC . 

Editing parts 
You can move a part on a schematic page by selecting it and dragging it to a new 

location. You can use the Rotate or the Mirror command from the Edit menu. You can 
use the part editor to change the part’s physical appearance, and you can edit the part’s 
properties. When you edit a part on a schematic page, your edited part differs from the 
part in the library and exists only in your design; you can place another copy of the part 
you edited by using the Copy command from the Edit menu, and by dragging the part 
from the design cache. 

To edit the physical appearance of a part, select it, and either choose Part from the 
Edit menu or choose Edit Part from the right mouse button pop-up menu. To edit the 
properties of a part, select the part on the schematic page, and either choose Properties 
from the Edit menu, or choose Edit Properties from the right mouse button pop-up menu.  

Placing and editing power and ground symbols 
You can place power and ground symbols, and you can edit their names before or 

after placing them. You can also edit the text associated with the symbols. The name of a 
power symbol becomes the name of the global net that is created. 

Placing power and ground symbols  
Power and ground symbols are placed on a schematic page using the Power command 

or Ground command on the Place menu, or using the power tool or ground tool on the 
tool palette. Power and ground symbols are selected from libraries the same way parts are 
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selected from libraries. CAPSYM.OLB contains all the power and ground symbols 
shipped with Capture. 

Editing power and ground symbols  
You can change the name of a power or ground symbol by selecting the symbol on 

the schematic page, and either choosing Properties from the Edit menu, or choosing Edit 
Properties from the right mouse button pop-up menu. 

You can also double-click the symbol. This displays a dialog box in which you can 
edit the symbol’s name, then click OK. 

Placing and editing no-connect symbols 
A no-connect symbol (shown as an “X” attached to a pin) causes unused pins to be 

ignored by reports (such as Design Rules Check and netlists) that show unconnected pins. 
If a pin is connected, the no-connect symbol doesn’t affect the pin. They are pin 
properties. 

No-connect symbols are placed on pins on a schematic page using the No Connect 
command on the Place menu, or using the no-connect tool on the schematic page editor’s 
tool palette. 

Note All schematic page objects have right mouse button pop-up menus. These menus 
are context sensitive, displaying commands appropriate for the selected object. 

Searching for parts 
Capture can search for a particular part inside all the libraries it finds in the specified 

directory. 
To find a part: 
1) In the schematic page editor, choose Part from the Place menu. 
2) Click the Part Search button. The Part Search dialog box appears. 
3) Enter the part name you want to locate. 
Placing and editing off-page connectors 
Off-page connectors are used to connect signals to like-named off-page connectors 

and hierarchical ports on other schematic pages within the same schematic folder. 
Off-page connectors are stored in the CAPSYM.OLB library. 
To place an off-page connector, you use the Off-Page Connector command on the 

Place menu or the off-page connector tool on the tool palette. 
Placing wires 
When you connect a wire to a pin, Capture provides visual confirmation of the 

connection by removing the unconnected pin box on the pin. If two continuous wires 
cross at 90°, they are not electrically connected unless you create a junction by clicking 
the left mouse button as you draw a wire across an existing wire. 

You can determine whether wires or buses that cross each other are connected by the 
presence or absence of a junction. Unless a junction is present, wires or buses that cross 
each other are not connected. If you drag a net up to another net so that they touch,  
apture adds a junction where the nets meet and the two nets are connected. 

You can add a junction using the Place junction button on the schematic page editor’s 
toolbar, or by choosing Junction from the Place menu in the schematic page editor. You 
can place junctions anywhere on a wire or bus, but they only take effect when another 
object is connected at the junction’s location. You can remove a junction by selecting the 
junction and pressing D , or by placing another junction on top of the existing one. 
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Editing wires 
Capture makes it easy for you to modify the appearance and properties of a wire. You 

can implement most changes with two clicks of the mouse or a key combination. 
Moving wires 
To move a wire, select it and drag it to a new location; the wire stretches to maintain 

its connectivity. To break the wire’s connectivity, press A while you move it. To move a 
vertex, select a wire segment next to the vertex and drag the vertex to the new location. 

Adding and editing graphics and text 
You can create a wide variety of graphic shapes to add to your schematic pages.  
Placing text 
You can place text, in the font of your choice, on a schematic page or on a part to 

document your schematic page. 
Changing your view of a schematic page 
There are several ways to change your view of a schematic page. They include 

zooming to a smaller or larger view of the schematic page, centering a view on a 
particular position, and moving to a different location. You can also choose whether or 
not to display a grid or grid references. 

 
5.Saving projects, designs, and libraries 
 

When the project manager window is active, you can save a new or existing project, 
design, or library. The Save command saves all open documents referenced by the 
project, as well as the project itself. 

A Capture design file (.DSN) is associated with a project file (.OPJ). Each time you 
use the Save As command from the File menu to save a design file to another name or 
directory, you should also use Save As for the project file. 

The Save As command saves files depending on what you have selected in the project 
manager. 
! If one or more designs or libraries are selected, Capture prompts you to save each 

file in turn. 
! If no top-level folders (Design Resources or Outputs) are selected, and items other 

than designs or libraries are selected, the Save As command is unavailable. 
! If no designs or libraries are selected in the project manager, Capture prompts you 

to save the project. 
To save a new design or library 
1) With the design or library selected in the project manager, from the File menu, 

choose Save. The Save As dialog box displays. 
2) Enter a name for the design or library in the File name text box, specify a location, 

then choose the Save button. 
The design or library is saved, and the project manager remains open. When you 

close the project, Capture prompts you to save the project file. 
To save an existing project 
With the Design Resources or Output folder selected, choose Save from the File 

menu. 
The project is saved, and remains open in the Capture session frame. 
Using the Save As command 
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The following process saves a .DSN file and a .OPJ file into the same directory so 
you can continue editing the current project without altering the original files. 

1) In the project manager, select the design file. 
2) From the File menu, choose Save As. 
3) Change the drive and directory as appropriate, then select the file name and click 

Save. 
4) Select the Design Resources folder. 
5) From the File menu, choose Save As. 
6) Change the drive and directory as appropriate, then select the file name and click 

Save. 
Archiving a project 
When the project manager window is active, you can archive a project. Archiving 

saves all files related to your project in the specified directory. Specifically, this 
command saves your project files (*.OPJ), design files (*.DSN), and library files 
(*.OLB) in the Design Resources folder. You can include output files and library files, 
like *.OLB files in the Library folder and *.VHD files. 

To archive a project: 
1) Make sure that the project you want to archive is active. 
2) From the project manager’s File menu, choose Archive Project. The Archive 

Project dialog box appears. 
3) Select the types of additional files you want archived with your project. If you 

don’t select any of the options (Library files, Output files, Referenced projects), Capture 
automatically archives your project (*.OPJ) and design files (*.DSN). 

4) Enter or browse to the directory in which you want to archive your project. 
5) Click OK. Capture archives your project with all the selected external files to the 

specified directory. The working directory does not change to the archive directory. 
 

6.Creating a netlist 
 

After you finish placing and connecting parts in the schematic page editor, use the 
project manager’s Tools menu commands to help you complete the design process. 

Annotating 
After you place parts on a schematic page, all parts need to be uniquely identified 

using the Annotate command on the project manager’s Tools menu. This tool assigns 
unique part references to each part in a project. You use Annotate after you’ve placed all 
parts and before you use other Capture tools.  

To annotate: 
1) In the project manager, select the schematic pages on which to annotate. 
2) From the project manager’s Tools menu, choose Annotate. 
or 
Choose the annotate tool from the toolbar. 
The Annotate dialog box displays. 
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Figure 2. Before annotation. 
 

Figure 3. After annotation. 

 
3) Set the options in this dialog box as necessary. You can specify whether to update 

the entire project or just the schematic pages selected in the project manager, whether to 
update the part references that haven’t yet been updated, update all part references, or 
reset part references so that they have question marks in their names. These options are 
described in the section Annotate dialog box. 

4) When the Annotate dialog box has the settings you want, click OK to begin the 
update. 

Checking for design rules violations 
The Design Rules Check tool scans schematic designs and checks for conformance to 

basic design and electrical rules. The results of this check are marked on the schematic 
pages with DRC markers, and are also listed in a report. This makes it easy to locate and 
fix design or electrical errors.  

The Design Rules Check reports two categories of electrical rules violations: 
! Errors that should be fixed. 
! Warnings of situations that may or may not be acceptable in your project. 
To check for design rules violations: 
1) In the project manager, select the schematic pages that you want to check for 

design rules violations. 
2) From the project manager’s Tools menu, choose Design Rules Check. 
or 
Choose the design rules check tool from the toolbar. 
The Design Rules Check dialog box appears. 
Using the Create Netlist tool 
Before you create a netlist, be sure your project is complete, has been annotated 

(using Capture’s Annotate command), and is free from electrical rule violations. 
To create a netlist: 
1) In the project manager, select your design. 
2) From the Tools menu, choose Create Netlist. The Create Netlist dialog box 

displays. 
3) Choose a netlist format tab. 
4) In the Netlist File text box, enter a name for the output file. If the selected format 

creates an additional file (such as a map file or pinlist file), enter its filename in the 
second text box. 



 13 

5) If necessary, set the Part Value and PCB Footprint combined property strings to 
reflect the information you want in the netlist. 

6) If necessary, set the format-specific options in the Options group box, and click 
OK to close the Netlist Options dialog box. 

7) Click OK to create the netlist. 
Creating reports 
Capture provides two report tools that you can use to produce lists of the things 

contained in your project: Bill of Materials and Cross Reference. 
Creating a bill of materials 
You can use the Bill of Materials command from the project manager’s Tools menu 

to create a bill of materials in a file which you can then print using a word processor or 
text editor. The bill of materials includes the properties item, quantity, reference, and part 
value. You can customize the report to include other properties. 

Creating a cross reference report 
The Cross Reference tool creates a report of all parts with their part references and 

part names. You may specify that the report also give the coordinates of each part. 
 

7.Using Capture with OrCAD Layout 
 

Preparing your Capture design for use with Layout 
Preparing a Capture design for Layout is a two-part process. First, you must create a 

valid design. Then, you need to create a netlist in an .MNL file format in Capture that you 
can read into Layout. 

Creating a netlist for use in Layout 
After you prepare your design in Capture and it is free from design rules violations, 

you can create a netlist (.MNL) file for use with Layout. A copy of the LAYOUT.INI file 
must exist in the same directory as CAPTURE.EXE to generate a netlist. 

To create a netlist for use in Layout: 
1) Open the Capture design. 
2) Select the design in the project manager and, from the Tools menu, choose Create 

Netlist. The Create Netlist dialog box appears. 
3) Select the Layout tab. 
4) In the PCB Footprint group box, ensure that {PCB Footprint} appears in the 

Combined property string text box. 
5) In the Netlist File text box, ensure that the path to the netlist file is correct. The 

netlist takes the name of the Capture project and adds a .MNL extension. 
6) Click OK. Capture processes the netlist, then creates a .MNL file and saves it in 

the directory specified in step 5. 
Note Save your Capture design before creating a netlist. 
If Capture does not create a .MNL file, check the Capture session log or the .ERR file 

in the target directory for the .MNL file. 
Loading a new netlist into Layout 
You can bring Capture netlist information into layout in two ways: 
! Choose one of the AutoECO options to merge the netlist with the board file 
! Select the Run ECO to Layout option in Capture’s Create Netlist dialog box to 

automatically communicate modifications to Layout 



 14 

If the board file is open in Layout when you update the netlist file, Layout 
automatically displays a dialog box asking if you want to load the new netlist file. If the 
board file is not open when the netlist changes, Layout prompts you to load the modified 
netlist when you re-open the board file. 

Use the following procedure to forward annotate information from Capture to Layout. 
In Capture: 
1) In the project manager, open the design for which you are going to create a netlist. 
2) From the Tools menu, choose Create Netlist. 
3) In the Create Netlist dialog box, choose the Layout tab. 
4) Select the Run ECO to Layout option. 
5) In the Netlist File text box, enter a name for the output file using an .MNL file 

extension. 
6) Click OK. The Create Netlist dialog box closes and creates the .MNL file. 
In Layout: 
7) From the session frames’s File menu, choose New. 
8) In the Load Template File dialog box, select a technology file (.TCH), then click 

OK. 
9) In the Load Netlist File dialog box, select the netlist file with the .MNL file 

extension that you created in step 6, then click OK. 
10) In the Save MAX Board dialog box, select a name for a new output file with a 

.MAX file extension, then click OK. 
If AutoECO is unable to find a designated footprint, a dialog box opens so that you 

can link footprints with components.  
 

Section 3. Introduction to Layout 
 

1.Introduction 
 

Features and design working flow of OrCAD Layout include: 
1) Using a schematic capture toll, such as OrCAD Capture, you create a Layout-

compatible netlist. 
The netlist contains much of the infomation that Layout uses to produce the board. 
If you change the netlist after back annotation in Layout and Capture, layout’s 

AutoECO utility automatically updates the board file. 
2) The next step in the design flow is placing components. 
3) After component placement, you can either manually route or AutoRoute the 

board. 
4) After routing, you can perform cross probing. Using cross probing, selecting a net 

in Capture highlights the corresponding track in Layout. Conversely, selecting as track in 
Layout highlights the corresponding net in Capture. 

5) For most processing, Layout produces hardcopy on printers and plotters, and also 
produces Gerber files, DXF files, and a wide variety of report files. 

6) You can preview and edit your Gerber filed with Layout’s external Gerber editor, 
which is known as GerbTool. 

 
2.Starting a new design and setting up the board 
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In Layout, you need to set up the environment when you create a new board design, 

which includes:  
! Define resource files and target directory for the design 
! Specify the component types used in the design   
! Define the manufacturing technology and complexity 
! Select color settings for the graphical display of your design 
You can start a new design from Layout’s session frame, or from the design window. 
From the session frame’s File menu, choose New, then select a technology template 

(.tch file) for the new design, then choose the Open button. After reading the description 
of a technology template, choose Continue. Next, select the netlist (.mnl file) that 
provides the connectivity information and component types for your new design, then 
choose the Open button. Specify a filename and directory location for the new design, 
then choose the Save button. Layout’s AutoECO utility creates the board file. 

Note In the design window, you can load a new technology template at any time. In 
order to do that, from the File menu, choose Load, select a technology template (.tch file) 
then choose Open button. 

Next, you can edit the board outline that was supplied by the technology template, or 
create a new board outline. 

Note Layout requires exactly one board outline, on the global layer. 
Creating a board outline 
1) From the Tool menu, choose Dimension, then choose Datum. Click on the lower 

left corner of the board outline to place the datum (to provide a starting grid for 
component placement). Press HOME to redraw the screen. 

Note Placing the datum in the lower-left corner of the board outline gives you 
positive X, Y coordinates, while placing it in other corners gives you negative 
coordinates (in your reports and post processing results). In addition, since the board 
datum is used for all grids, if you move the datum after component placement, your place, 
routing, and via grids will all be affected. And, you may have difficulty replacing the 
datum at the precise location you moved it from. 

2) Choose the obstacle toolbar button. 
3) From the pop-up menu, choose New, then from the pop-up menu, choose 

Properties. The Edit Obstacle dialog box displays. 
4) From the Obstacle Type drop-down list, select Board outline. 
5) In the Width text box, enter a value for the outline’s width. 
6) From the Obstacle Layer drop-down list, select Global Layer, then choose the OK 

button. The Edit Obstacle dialog box closes. 
7) Move to the point on the board at which you want to start drawing the outline, then 

click the left mouse button to insert the first corner. 
Note Since a board outline must be a closed polygon, Layout automatically begins 

forming a closed area after you insert the first corner of the board outline, and 
automatically closes the polygon for you if you don’t close it yourself. 

8) Continue clicking the left mouse button to insert corners. 
9) After you click to insert the last corner, choose Finish from the pop-up menu. 

Layout automatically completes the board outline. 
Defining the layer stack 
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Routing and documentation layers are defined in the Layers spreadsheet. Using the 
spreadsheet, you can define the number of routing layers that will be used for the board. 
If you plan to have a board with four routing layers (TOP, BOTTOM, INNER1, and 
INNER2) and two plane layers (POWER, GROUND), then you need to define the layers 
in a technology template (.TCH) or a board template (.TPL). 

Note It is better to have too many routing or plane layers defined than too few (if 
you’re unsure of the number you will need) before reading in a netlist, because you can 
decrease the number of the layers later, by designating them as unused. 

After defining the layer stack, you can save the information to a board template 
(.TPL) for use in future boards. 

1) Choose the spreadsheet toolbar button, then choose Layers. The Layers 
spreadsheet displays. 

2) Review the type assignments for the routing layers and double-click in the Layer 
Name column of a layer you want to modify. The Edit Layer dialog box displays. 

3) In the Layer Type group box, select the desired option (for example, to disable a 
layer for routing, select Unused Routing; to define an additional plane layer, select Plane 
Layer). 

4) If you changed a routing layer to a plane layer, change the Layer LibName to 
PLANE. 

5) Choose the OK button. 
Note Do not delete layers from the Layers spreadsheet. To disable a layer, double-

click on it, then specify it as Unused Routing in the Edit Layer dialog box. 
Setting system grids 
Using the System Settings dialog box, you can set five distinct grid settings. The grid 

values that you assign determine the resolution of the pointer location coordinates given 
in the status bar in the lower left corner. For example, if the obstacle tool is selected and 
the Place grid is set to 100 mils, the coordinates that display are accurate to 100 mils. 

Grid values are in user-specified units that you set in the Display Units group box in 
the System Settings dialog box. If you want to use fractions in your grid values, enter a 
space character following the integer and use a forward slash as the division character 
(for example, 8 1/3). You can also use decimals for rational numbers. 

To set system grids: 
1) From the Options menu, choose System Settings. The System Settings dialog box 

displays. 
2) Set these options, then choose the OK button. 
Visible grid Assigns a display grid based on the X and Y coordinates (for example, if 

you’re using mils, a setting of 200 would place a grid dot at every 200 mils). 
Detail grid Assigns a drawing grid (for lines and text) based on the X and Y 

coordinates. 
Place grid Assigns a component placement grid based on the X and Y coordinates. 

For greatest routing efficiency, this value needs to be a multiple of the routing grid. The 
datum, or origin, of footprints is constrained to this grid. 

Routing grid Assigns a grid used for routing (see the routing grid chart below for 
suggested settings). 

Via grid Assigns a grid upon which you or the router can place vias. 
Here are some rules of thumb for setting the grids: 
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! For efficient routing performance, the routing grid and via grid should have the 
same value. 

! The place grid must be a multiple of the routing and via grids. 
! The routing grid should never be less than 5 mils. 
! The detail grid can be set as low as 1 mil for better resolution. 
! Components are placed on the place grid using the component datum, which is 

typically pad 1 (unless the component has been modified). 
For more details about grid, refer to Appendix A. 
Setting units of measurement 
In Layout, you can set numeric data to display in mils, inches, microns, millimeters, 

or centimeters. You can change these values as needed (for example, you can route the 
board in inches or mils, then confirm pad locations within footprints in millimeters). 

Note If your board uses metric units, you can achieve the best precision by using the 
METRIC.TCH technology template. With your board open in Layout, choose Load from 
the File menu, select METRIC.TCH, then choose the Open button. After METRIC.TCH 
loads, save your board. 

To set measurement units: 
1) Open your board in Layout. 
2) From the Options menu, choose System Settings. The System Settings dialog box 

displays. 
3) Select mils, inches, microns, millimeters, or centimeters. 
4) Choose the OK button. 
Note Once you decide on a measurement unit, you should stick with it and not change 

it in either your board or your schematic. If you back annotate to your schematic, then 
change to another measurement unit, it may cause board corruption problems. 

Defining global spacing values 
Global spacing values set rules for spacing between the various objects on the board. 

You can define global spacing values for the board using the Edit Spacing dialog box, 
which is accessed from the Route Spacing spreadsheet (choose the spreadsheet toolbar 
button, choose Strategy, then choose Route Spacing). You can save spacing requirements 
in a board template (.TPL). 

Uniform spacing requirements per layer reduce processing time. 
Note To globally assign the same spacing to all layers, double-click in the Layer 

Name title cell in the Route Spacing spreadsheet. When the Edit Spacing dialog box 
displays, enter a value in the appropriate text box (for example, enter a value for Track to 
Track Spacing), then choose the OK button. 

1) Choose the spreadsheet toolbar button, choose Strategy, then choose Route 
Spacing. The Route Spacing spreadsheet displays. 

2) Double-click on the layer you want to modify. The Edit Spacing dialog box 
displays. 

3) Set these options, then choose the OK button. 
Track to Track Spacing Tracks are defined as any routed track and copper obstacles 

(such as keepouts and place outlines). Track-to-track spacing specifies the minimum 
space required between tracks of different nets, and between tracks and obstacles of 
different nets. 
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Track to Via Spacing Track-to-via (and obstacle-to-via) spacing specifies the 
minimum space required between vias and tracks of different nets.  

Track to Pad Spacing Track-to-pad (and obstacle-to-pad) spacing specifies the 
minimum space required between pads and tracks of different nets. 

Via to Via Spacing Specifies the minimum space required between vias of different 
nets. 

Via to Pad Spacing Specifies the minimum space required between pads and vias of 
the same net (as well as different nets, which is the usual case). For instance, to keep a 
distance of 25 mils between your SMT pads and the fanout vias connected to the pads, set 
Via to Pad Spacing to 25. 

Pad to Pad Spacing Specifies the minimum space required between pads of different 
nets. 

Defining padstacks 
Padstacks define the pads of the footprint. They possess properties on each layer of 

the board, such as shape and size. If you are using the standard Layout footprint libraries, 
or if you have made your own footprints using Layout standards, you have used 
padstacks T1 through T7 to create most of the standard through-hole components in your 
library. 

Note Don’t name your custom padstacks using the names T1 through T7, because 
they will be overwritten by technology template padstacks whenever you load a 
technology template. Also, be sure to define through-hole padstacks on all layers, 
including unused layers. Otherwise, you may unintentionally create blind or buried vias. 
Surface-mount pads, on the other hand, are not defined on internal layers. 

Using vias 
You can define the types of vias that you want to use when routing your board, either 

vias or free vias. Free vias (denoted by the letters FV) are ignored by Layout’s board 
cleanup routines, so you can place them on your board and have them stay there, as long 
as they are attached to a net. They are preserved through AutoECO, unless the net or 
routed track they are connected to is entirely deleted or removed from the board. Layout 
regards free vias as stand-alone components: you can shove them, place them in isolation 
(free of tracks), or connect them to multiple tracks on the same net. You can use free vias 
for special purposes, such as zero-length fanouts of ball grid array (BGA) components 
and the “stitching” of plane layers. 

Layout provides one defined via and fifteen undefined vias. You define additional 
vias in the Edit Padstack dialog box (from the Padstacks spreadsheet) to make them 
available for routing. Then, using the Assign Via dialog box (from the Nets spreadsheet), 
you can assign a specific via to be used when routing a particular net. 

Setting colors 
The last step in the setup process is setting object or layer colors. 
 

3.Placing components 
 

Once you board is set up, you can begin placing components. Components can be 
placed individually or in groups, taking advantage of a variety of powerful placement 
commands. 

Preparing the board for component placement 
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Before you begin placing components manually, it is important to set up the board 
properly. Use the list below as a preplacement checklist: 
! Check the board, place, and insertion outlines 
! Check the place grid 
! Check mirror layer or library layer settings 
! Weight and color-code nets 
! Check gate and pin data 
! Check preplaced components and secure them on the board using the Lock or Fix 

commands 
! Create component height keepins and keepouts, or group keepins and keepouts 
Placing components manually 
There are several commands available in Layout to assist you in manually placing 

components on a board. You can place components one at a time or in groups. 
Use the Queue For Placement command to make a component or group of 

components available for placement based on a set of criteria (reference designator, 
footprint name, or first letters with wildcards), then place the components individually 
using the Select Next command. 

To place components individually: 
1) Choose the component toolbar button. 
2) From the pop-up menu, choose Queue For Placement. The Component Selection 

Criteria dialog box displays. 
Note The Queue For Placement command and the Select Any command display the 

same Component Selection Criteria dialog box, but the commands work differently. The 
Queue For Placement command makes certain components available for placement in 
conjunction with using the Select Next command. The Select Any command, on the other 
hand, actually selects specified components or groups for placement and attaches them to 
your cursor. 

3) Enter the reference designator (or other criteria) of the component that you want to 
place in the appropriate text box and choose the OK button. (Choose the dialog box’s 
Help button for information on the options in the dialog box.) 

4) From the Edit menu, choose Select Next. The component snaps to the cursor. If 
you selected a group (such as all components beginning with the letter U), then the 
component with the greatest number of connections that meets the specification snaps to 
the cursor. 

5) Drag the component to the desired location and click the left mouse button to place 
it. 

Selecting the next components for placement 
Use the Place command on the pop-up menu to display a dialog box that lists the 

components yet to be placed. If you made components available for placement according 
to certain criteria (using the Component Selection Criteria dialog box), Layout displays 
only the components that remain to be placed that meet those criteria. From this list, you 
can select the next component that you want to place. The default selection that displays 
in the dialog box is the one that Layout would automatically choose if you had used the 
Select Next command. You can accept the default, or enter a new choice. 

To select the next component for placement using Select Next: 
1) Choose the component toolbar button. 
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2) From the pop-up menu, choose Place. The Select Next dialog box displays. 
3) Select a component for placement, then choose the OK button. 
Checking placement 
You should check the placement of a board using Placement Spacing Violations, the 

density graph, and the placement information in the Statistics spreadsheet. 
Viewing placement statistics 
When you finish placing components on the board, you can view the component 

placement statistics in the Statistics spreadsheet. The spreadsheet shows the percentage 
and number of components placed, how many were placed off the board, how many were 
unplaced, and how many were placed in clusters. 

To view placement statistics: 
1) Choose the spreadsheet toolbar button, then choose Statistics. The Statistics 

spreadsheet displays. 
2) Scroll until you find the % Placed row, which is the beginning of the placement 

data. 
3) Close the spreadsheet when you are finished viewing the statistics. 

 
4.Routing connections between components 

 
After you’ve placed the components on the board, you can route the electrical 

connections between the components. 
When you view the board before you’ve done any routing, you’ll see that the parts 

have many fine lines running between them. These lines are known as a ratsnest. A 
connection is an electrical path between two pins: a ratsnest represents an unrouted 
connection, while a track represents a routed connection. 

Autoroutig 
Layout’s autorouter uses sweep, shove, and interactive routing technology to provide 

maximum autorouting power and flexibility. 
Steps in the autorouting process is listed below: 
1) Set the net properties. 
2) Check the board outline, via definitions, and routing and via grids. 
3) Route the power and ground nets. 
4) Preroute critical nets. 
5) Load a routing strategy file. 
6) Run the autorouter. 
7) Optimize routing using Layout’s other routing tools. 
Checking the board outline, via definitions, and routing and via grids 
Before you route, you need to check the settings for the board outline, vias, routing 

grid, and via grid. 
! Verify that the board outline has a desirable amount of internal clearance, that 

there is only one board outline,and that it is on the global layer. 
! Inspect the vias in the Padstacks spreadsheet to make sure that they are the right 

size and on the correct layers. 
! Verify that the routing grid and via grid match for the placement of tracks. 
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Loading a routing strategy file 
A routing strategy file determines which default routing layers to use, when to use 

vias, which direction the track should travel, which colors to use for routes, and the size 
of the active routing window. There are many routing strategy files provided with 
Layout. Load the routing strategy file that is most suitable for your board. 

Routing power and ground 
Plane layers are typically used for power (VCC) and ground (GND). When routing 

multilayer boards, it is essential to route power and ground first. To do so, you enable the 
power and ground nets for routing, while disabling all the other signals for routing. After 
routing power and ground nets, you must disable them and enable all other signals for 
routing. Then you can route the remaining signals. 

Note Before you can route power and ground, you need to designate plane layers in 
the layer stack. For information on designating layers as plane layers, see Defining the 
layer stack. 

When you’re finished routing power and ground, you need to disable those nets. 
Routing the critical nets 
Before you autoroute the board, you should manually route the critical nets and lock 

them onto the board. 
Manually routing using shove track mode 
When you use shove track mode, Layout shoves other tracks out of the way of the 

track that you are currently routing. With this mode, you can pick up individual 
connections and route them aided by the shove capability, manually route critical tracks, 
and edit tracks and vertices. 

To use shove track mode: 
1) Choose the shove track toolbar button. 
2) Define the DRC box size to encompass your area of interest. 
3) Select a connection with the left mouse button. The connection attaches to the 

pointer. 
4) Drag the pointer to draw a track on the board. 
5) Click the left mouse button or press the SPACEBAR to create vertices (corners) 

in the track. 
6) When drawing the last segment for the connection, choose Finish from the pop-up 

menu. The track automatically connects to the center of the pad. A complete connection 
is indicated by the cursor changing size and the ratsnest disappearing from the pointer. 

Running Autoroute 
From Auto menu, choose Autoroute, and then Board. Layout performs up to six 

routing sweeps. The settings in the routing strategy file determine the actual routing 
parameters. 

Checking routing 
You should check the routing of a board using Route Spacing Violations, the density 

graph, and the routing information in the Statistics spreadsheet. 
When you’ve finished routing the board, you can view the routing statistics in the 

Statistics spreadsheet. 
 

5.Finishing the design 
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You need to take several steps to finish your board, which include checking design 
rules, querying any errors found, removing violations, cleaning up your design, renaming 
your components, back annotating the board information to the schematic, running the 
post processor, and creating reports. 

Checking design rules 
Running the Design Rule Check command tests the integrity of your board by 

verifying the board’s adherence to design rules. 
To check design rules: 

1) From the Auto menu, choose Design Rule Check. The Check Design Rules dialog 
box displays.  

2) Select from the following options, then choose the OK button. Layout performs the 
specified checks and marks the errors with circles on the board. 

Investigating errors 
When you run Design Rule Check, the errors are marked on the board with circles. 

You can query an error to receive a full description of the problem. 
To query errors: 
1) Choose the query toolbar button. The query window displays. 
2) Choose the error toolbar button. 
3) Select an error circle. A description of the error displays in the query window. 
4) Take the necessary action to reconcile the error. 
Removing violations 
Remove Violations removes the errors, allowing you to reroute the problem area. 
To remove violations: 
1) From the Auto menu, choose Remove Violations, then choose Board. 
or 
From the Auto menu, choose Remove Violations, then choose DRC/Route Box. 
Cleaning up your design 
Cleanup Design checks for aesthetic and manufacturing problems (such as off-grid 

90° angles, acute angles, bad copper share, pad exits, and overlapping vias) that might 
have been created in the process of routing the board. You should always run Design 
Rule Check after running Cleanup Design. 

To clean up your design: 
1) From the Auto menu, choose Cleanup Design. 
Creating reports 
The Create Reports command brings up the Generate Reports dialog box, within 

which you select the output reports you would like to have generated. 
To create reports: 
1) From the Auto menu, choose Create Reports. The Generate Reports dialog box 

displays. 
2) Select the reports you want generated (choose the dialog box’s Help button for 

information on the reports), then choose the OK button. 
 
 

For more technology support, please go on-line: 
      www.orcad.com/technical/technical.asp 

http://www.orcad.com/technical/technical.asp
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Appendix A. A synopsis of routing grids 

 
Routing 

grid 
Uses 

  
Compatible grids 25, 121/2, 81/3, and 61/4: 
  
25, 121/2 Use for less dense (usually .45 density or greater) 
 through-hole and SMT boards, and for routing 
 one track between IC pins. 
  
81/3 Use for a secondary grid on through-hole boards, 
 and for a primary grid on SMT boards. Use as a 
 secondary grid with 25 mils grid only if the 25 
 mils grid initially routes 95% or better. 
  
61/4 Use for 6/6 technology, or denser one-between 
 boards. 
  
Compatible grids 20 and 10: 
  
20 Use for through-hole boards only. This is the most 
 efficient way to route two tracks between IC pins. 
  
10 Use for through-hole, two-between boards placed 
 on a 50 mils grid, and for SMT boards using 10/10 
 technology. Also, use for special cases when a 20 
 mils grid causes off-grid jogs. 
  
Compatible grids 25, 20, and 10: 
  
5 Use for extremely dense SMT boards that use 5 
 mils spacing and 5 mils track width (for mixed 
 inch and metric technologies). 

Note Incompatible grids (such as 20 and 25) should not be mixed on the same board. 
If you find it necessary to do so, use a 5 mils grid for the final reroute pass. Also, a via 
grid smaller than the routing grid (for instance, a 5 mils via grid on a 25 mils grid board) 
increases completion on difficult SMT boards. Of course, if a board is very dense, via 
sizes should by reduced to the minimum size possible, since vias are responsible for much 
of the channel blockage during routing. 
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