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1 Introduction to 3D GameStudio
1.1 Creating a room
1. Start 3dGameStudio.

2. Click File and then New.

3. Now build a room by clicking Object-Add cube-Large.

4. Scale the cube by clicking the 12th button from the upper left. Then click on the corner of the cube and drag it to make it bigger.

5. Now click Edit-Hollow block. The cube is now a room with a ceiling.

6. Now click Object-Scope-Scope down. The room will be highlighted red.

7. Now click on the ceiling and press Delete to remove the roof. You can delete walls or the floor the same way to create a space you like.

8. When you're done, press Object-Scope-Scope up. You have now built your first room!

9. To see what your room looks like click the BUILD button, and click on Build Level. Then click the Go! (Run) button.  
- You can now see your room. Notice that you can walk through rooms
  at this point. 
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1.2 Texturing a room using WADs
1. Textures are called WADs in 3D GameStudio.  There are already some WADs loaded, but you can also add new ones.  

2. To add a new WAD click Texture- Texture manager-Add wad. Browse to find standard.wad, which contains many textures. Your new WAD shows on the left under the Textures tab.  Click OK to exit the texture manager.

3. To add texture to your whole room, select the texture, and select the room. (It will be highlighted in red).  Click Texture-Apply to Object. OR, you can also select the room, and right click on the texture and choose Apply.
4. If you want to texture different walls, select the wall using the Object-Scope-Scope Down function as before. 
5. Build and Go!
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1.3 Connecting rooms with doors
1. Build two rooms next to each other as below:
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2. Now create a door like cube and place it between the rooms. Make sure it sticks out on both sides and stands on the floor.

3. Now with the door cube selected press Edit-CSG subtract.

4. Now press delete. You have now made an opening between 2 rooms.

5. Load the entity porta.wmb and place it in the door site.
(It’s too small but we are learning how to make the door work.)

6. Save your level as “testdoor”

7. Click File-Map properties and press New script. The name “testdoor” will appear.

8. Now give the porta the door action and place an entity with the player Walk action.

9. Now build and run it. When you walk to the door; press spacebar and the door will open. 

10. Press spacebar again and the door will close.

11. In the model editor, (med), you can create your own door. As long as you give it the door action it will work.
1.4 Add an entity to the room
1. Click Object-Load entity
2. Find the entity named guard.mdl in your 3d GameStudio directory and open it.

3. In the viewing screens you can see your entity appear.

4. Place it in the middle of the room with his feet on the ground

5. To see your entity in the room press the BUILD button and make sure “update entities” is selected.
6. Now you can walk through the room and you see the guard standing (Moving in place).
7. Now save your textured room with guard as “practice”.
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1.5 Make the player walk your way
1. Click File-Open: “practice”
2. Click File-Map properties
3. Change the script by pressing new. When you do this a new name comes as script.  In this case it will be “practice”
4. Select the guard and right click on it, choose properties.

5. Set skill 1 to 1 and press the button next to action.

6. Choose player walk, okay and close this window

7. Build and Go!
8. Now you have your first level. Press F7 to switch between first person view and 2nd person. 
9. Use the arrow keys to move the guard around in your room.

10. Save your file as practice
1.6 Create enemies (that shoot!)
1. Place a new entity as before. Open the warlock.mdl

2. Now right click the warlock entity and choose robot 2 as action.

3. Save, Build and Go!
4. Now walk in front of the warlock and see what happens.

5. Wow the enemy is shooting at you!
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1.7 Pick up a weapon
1. Create new entity. 
2. Open the mgun_1st.mdl and place it in the middle of the room on the floor.
3. Now right click the gun and give it the GUN action.

4. Save, Build and Go!
5. Walk to the gun to pick it up.
6. Use the control key to fire... Now you can shoot the warlock.....

7. The warlock will explode after it is hit several times. This is because we gave it the robot2 action.
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1.8 Make an entity patrol along a path
1. Create a new level (Room).
2. Load the guard.mdl entity

3. Right click the guard and give it the action : Patrol_path
4. Now we have to create a path that the guard will follow

5. Click Object-Add path
6. A starting point will appear. (A cube with dot in it.)

7. Place it where you want the path to start.

8. Now click Vertex move (13th button from the upper left.)

9. Hold down the ctrl key and click on the starting point. Now you can drag another patrol path point to wherever you want. Repeat this and make the circle complete.

10. Save, Build and Go!

11. You will see the guard patrolling along the path we just created.
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1.9 The hero’s death
1. Open with notepad the practice.wdl file (remember you made this level).
2. Now after the last line copy the following code :

ACTION player_prog
{
MY.NARROW = ON; // use narrow hull!
MY.FAT = OFF;
MY.TRIGGER_RANGE = 5;
MY._MOVEMODE = _MODE_WALKING;
MY._FORCE = 0.75;
MY._BANKING = -0.1;
SET MY.__STRAFE,ON;
SET MY.__BOB,ON;
SET MY.__TRIGGER,ON;
CALL player_walk;
CALL player_fight;
CALL drop_shadow;
} 


3. Now save it as practice.wdl

4. Open 3d GameStudio, File-Open and open practice.
5. Right click the guard and give him the Player_Prog action.
6. Now build and run and look after you've been hit several times you die. The warlock can kill you now.
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1.10 Add music to your level
1. Open the office.wdl file in notepad or SED. Than save it as office2.wdl

2. Now open office2.wdl

3. Search for the line that says : MUSIC testsong = <ribanna.mid>;

4. Change the name ribanna.mid to the name of your midi file.

5. Make sure the midi file is in your work directory.
6. Now save office2.wdl
7. Open  3d GameStudio; File- New File-Map properties, and click on the folder to open the script you called office2.wdl.
8. Now build and run the level.

9. You now hear the music you just added.
2 Using Med, the Model Editor

In this section, you will find examples to create:

1) Models

2) Apply skins

3) Animation

4) Other characters

2.1 Create the game models
Create in MED (Model Editor) or any 3D program the main player. 

You can use anim8or,  at: http://www.anim8or.com/main/
Our main player will be made out of six spheres: one for the head, one for the body, one for the hands and two for the feet. Keep some distance between the spheres this is easier to animate later. Our character will be given the actions: Walk, Jump, Death, Attack.

Make you sphere dude like this:
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Now import the model in MED and place it (rotate it) like this:
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2.2 Apply skin
Give our sphere dude a skin. How do we do this?

In MED, click on View > Skins.

Click Edit > Create MDL mapping

Now you’ll see a black texture with yellow lines in the shape of our sphere dude.

Click File > Export (in skin editor) and save the picture as: sphere.bmp

Open up the sphere.bmp in any photo/paint editing program.

Just paint on the yellow lines and make it look like this:
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Save it again as Sphere.bmp and overwrite the old file.

Go back to MED and click File > Import
Choose the skin you just made (Sphere.bmp) and import it

Click Edit >Add new skin.

And there it is the sphere dude is fully skinned.

It has to look a bit like this:
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2.3 Animation

So we have now our model made with skin. Now it’s time to animate it.

In MED (with the skinned sphere dude in it), click  Edit  > change frame name

Now change the name in walk1.

Each animation has to have a name sequence. Later these actions will be called from the WDL script.

Click Edit > Add new frame. It automatically will call the frame walk2 which is good because we are creating a walk animation cycle.

Now select one of his feet and move it foreward. Select the other foot and move it  backwards.

Click again Edit > Add new frame. It automatically will call the frame Walk3.

Select the feet again and reverse there position. You could also move the hands or head a little. Keep repeating this until you got a nice Walk animation cycle. Here, there are only 4 frames for the walk action and only head and feet are moved. 

Note: Make sure your last animation frame ends in the same position as your first frame.

Now let’s make the dude jump.

Click Edit > New frame. Change the name into jump1 (remember why ?)

Continue to make a jump animation cycle the same way as you made the walk animation.

Do the same for Death and Attack (you can put his feet next to each other and his hands on his back for the Attack animation and spread all spheres for the die animation.) 

In our example, number of frames used for the animations:

· Walk 4

· Jump 6

· Death 7

· Attack 1

In the lower left corner in MED you’ll see a play button. Press this and you will see that you just made animations in action.

You have now made a skinned and animated character.

Click save and save it in your work folder as Sphere.mdl

Other Characters

We need to make some bad enemies you say? Open in MED your Sphere.mdl

Click View > Skins

Click Edit > Clear current skin

Now open in any paint/photo editing program your sphere.bmp file and make it look like this: 
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Save it as Evil.bmp

Now go back to MED and import the evil skin like you did before.

Click Edit>  Add new skin

Save it as evil.mdl

There you got your bad guy and we don’t have to animate it since the sphere dude already has the animations in it.

 In the game our characters will look like this:

[image: image5.png]



You can create the following models like you already learned, no animations are needed.

Bubble gun (use 5 spheres, Keep it easy)

Bomb (use 1 sphere 2 cylinders)

Ammo (Just a little sphere)

Health (use the sphere dude model scale it down)

Skin your models... If everything goes fine it should look like this:
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3 Creating a Level in WED

In this section, you will learn:

1) Creating a level 










(a) Create two rooms connected with a door

(b) Load entities
2) Creating actions
3) Creating panels

4) Creating paths

5) Inserting health bar and panel in game 
6) Some more scripting

3.1 Creating a level

3.1.1 Creating a room:

Remember you have done it earlier. We keep it easy so here is what we are going to do.

Open WED(world editor), Click File New.

Click: Object, Add primitive, Cube large

Use the scale button (12th button from the upper left) to scale your cube like this:
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Click: Edit > Hollow block Now you created a room without any doors or windows.

We are going to give the room a nice texture. How do we do that?

Here we go.

Click: Texture > Texture manager

A texture Wad manager window will appear.

Click: Add wad and select standard.wad

Close the manager window and on the right side of WED all the texture appear.

With the room selected (Red lined) Click: Object > Scope down The room will be highlighted with white lines.

Now select the floor so it is highlighted red. Scroll through the textures and right click the texture with the name: Checker1. Select apply. We’ve now added a nice texture to the floor.

Now do the same with the walls but choose the texture named: Gate1.

For the sealing take the texture named: Lightwall1

When you textured all walls click: Object > Scope up. The complete room will be high lighted with red lines again.

Click: Build Make sure level map is selected > GO!

Your room should look like this:
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With the room selected hold down the CTRL key, slide the room aside

You’ve just made an exact copy of your room. Make sure it is placed straight against the previous room like this :
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Now, how do we get from one room to another when there is no door?

Let’s make an opening and a door.

Click : Object > Add primitive > Small cube

Scale the cube so it has the shape of a door opening.

Place this door opening exactly at the border of where the 2 rooms are getting together.

Place it on the floor (the first line of the floor) and make sure it sticks out in both rooms like this:
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With the door opening selected click: Edit > CSG Subtract.

Press delete.

Click : Build with level map selected > Go ! 

Now you have just made two rooms with a door opening. This is the same way to make windows. It should look like this :
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You can use the scope function like you learned before and delete the ceilings (Roof) of the two rooms. You can add some sky to our level.

Create a cube that covers the complete rooms like this: 
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Give this cube the SKYBLUE texture.

Build your level GO!

You have made a nice looking sky there.

It should look like this:
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3.1.2 Load models:
Now, import our models into our game.

Click: Object > Load Entity 

Open your models into your level and place the models like this:
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Place the sphere dude, enemy, bomb on the ground.

Leave some little space between the floor and the bubble gun/Health models.

And done..... You just created a small nice looking level with your own models.

3.2 Creating actions
Open in Wed the level that you created. Save it as bubble.

Click  : File > Map properties

A map properties window will appear

Click : New

The name bubble will appear. Close this window.

You just made a standard wdl script for your game. Later on the Bubble.wdl file is where we will do the scripting.

But for now you Got all the standard WDL actions that 3DGS has for you.

Select the sphere dude model (The main player) and right click on it

Click properties. A properties window will open. Now click the button next where it says action.

Select Player_walk. Close this window.

You just gave your player the walk action. Remember when we made the walk animation?.

The action we gave it will call the walk animation. You will see this when we run the game but not yet.

Now right click the bubble gun model and give it the Logengun action. Select flag 1.

You selected flag 1 so your model will rotate in the game. The logengun action will be called from you standard.wdl file.

Do the same stuff with the other models and give them these actions :

Health model – Medipac action (make it rotate)

Enemy model - Robot _2 Action 

Ammo model - Ammo pack (make it rotate)

Now build the level twice: One time with level map selected and the second with entities selected.

Now run your level and see what it does.

· You can move the sphere dude with the arrow keys

· By pressing F7 you change the view

· The enemy is firing at you (It walks to you)

· You can pick up the bubble gun and shoot with it using CTRL key.

· You can kill the enemy by shooting at it

· You can pick up the ammo and the health models by touching them

All this stuff works because we gave them actions. The standard 3DGS wdls give us an easy way to make a shooter. The robot2 and logengun actions are called from the weapons.wdl and War.wdl files which are in our template folder. So you see 3DGS did a lot of scripting for us.

It’s up to you to script some new actions or effects and use them in our game.

This we will learn later.

3.3 Creating paths

How to make paths so you can make a model patrol along it? 

Open in Wed your Bubble level. Copy the enemy model.

With the enemy model selected hold down the CTRL key and slide it away.

No you got a copy of the model. Put it in the same room as your main player.
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Just set it in the corner like this:

Now click:  Objects > Add path

A small red square with a dot in it will appear.

Place this in front of your copy enemy model with a little space of the floor

Click the vertex move button. (It’s the 13th button from the upper left)

Hold down the CTRL key and slide away. A new point will be created.

Repeat this 3 times and create a path that goes through the complete room.

It should look like this:
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Now right click your copy of the enemy model and give it the patrol path action you should know how to do this by now.

Build your level and select update entities, then run your level.

You will see the copy enemy model patrolling across the room.

3.4 Creating panels
To make our game look more attractive we are going to create a panel.

This is simply a picture that covers the game except the parts that are pure black. Everything black will get transparent during the game so we can actually see the game in action.

How do we do that? 

Open any paint/photo edit program and create a new file picture with the size 640 X 480

Now remember that the real level should be visible in the black area. 

So create a black kind of viewing screen. For example it may look like this:
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Save it as spherep.bmp. 

The same thing here for the health bar we are going to make. Anything black will be transparent.

Open a new file with the size 216 X 38.

Again use your imagination; it could be painted every style you like. Here, I used colored bubbles, like this:
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Save it as health.pcx

3.5 Inserting health bar and panel in game 

Open your script bubble.wdl.

To insert our game panel (You should have saved it into the work directory as spherep.bmp)

Place this code right under the includes

BMAP spherep_map <spherep.bmp>;

PANEL spherep_panel

{

BMAP spherep_map;

LAYER 2;

FLAGS OVERLAY, REFRESH, VISIBLE;

}

Now save it again as bubble.wdl.

We have just a code that sends our made panel straight into the game.

Build and run your level and see your panel is inserted.

It should look a bit like this:
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Now we are going to insert our health bar. Open bubble.wdl like you did before.

Add this code at the bottom of your WDL.

Remember your own made health.pcx has to be in the work folder

bmap health_map = <health.pcx>; 

panel hbar_pan 

{ 

 hbar 20, 20, 230, health_map, 1, player._health; 

 flags = refresh, visible, overlay; 

}

Build and run and see your health bar in action. Each time you get hit 

The bar will become smaller. It should look a bit like this:
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Build and run. If your healthbar is gone you are dead and you die.
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Take a look what happens when you get your medipac, that’s right, your health gets restored.
4 Tailoring your level

In this section, we will:
1) Add some music
2) Make things explode

3) Make it snow

4) Use ammo

5) Making the menubar

4.1 Add some music to your level
Add the following code after the include files and before the main function.

string music_str ="mim.mid";     //Your file

var zzz;    //a variable to hold the media handle.

function start_music()

{


media_play (music_str,null,70); //play your file with volume 70


zzz = media_handle;

}

Find following line:

//start_music();
Remove the slash ‘//’ so that main function calls this function.

Build your level and run. You got a nice Mission Impossible theme in your level!

Isn’t that cool? 
4.2 Make things explode

Remember the bomb model you made? We are going to give it an exploder action but first we need to make it.
Put the following code in your main wdl at the bottom.

var exploder_pos[3]; 
function exploder_event()
{
if((EVENT_TYPE == EVENT_SHOOT && indicator == _GUNFIRE)
| | (EVENT_TYPE == EVENT_SCAN && indicator == _EXPLODE))
{
MY.EVENT = NULL;
my_pos.x = my.x;
my_pos.y = my.y;
my_pos.z = my.z;
morph(ACTOR_EXPLO,ME); 
MY._DIEFRAMES = ACTOR_EXPLO_FRAMES;
MY.FRAME = 1;
wait(1);
PLAY_ENTSOUND ME,explo_wham,1000;
MY.LIGHTRED = light_explo.RED;
MY.LIGHTGREEN = light_explo.GREEN;
MY.LIGHTBLUE = light_explo.BLUE;
MY.AMBIENT = 100;
MY.LIGHTRANGE += 50;
while(MY.FRAME < MY._DIEFRAMES)
{

wait(1);
MY.LIGHTRANGE += 15;
MY.LIGHTRED += 20 * TIME;
MY.LIGHTBLUE -= 20 * TIME;
MY.FRAME += TIME;

}
wait(1);
exploder_pos[0] = my.x;
exploder_pos[1] = my.y;
exploder_pos[2] = my.z;
remove(ME); 
range = 500;
damage = 200;
temp.PAN = 360; // complete sphere
temp.TILT = 360; // complete sphere
temp.Z = range; // range
indicator = _EXPLODE;
scan(exploder_pos,nullvector,temp);
}
} 


ACTION exploder
{

MY.ENABLE_SHOOT = ON; // sensible of gunshots
MY.ENABLE_SCAN = ON; // sensible of explosions and other scans
MY.EVENT = exploder_event;

} 

Save it.
Open your level in WED, and give the bomb the exploder action. When the bomb gets shot it’ll explode. Run away quick it can do damage to you too.
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4.3 Make it snow

Now we want it to snow in our level. So what we need is a snow action (something that drops snow flakes). 

Put the following code into your main wdl.

bmap snow_map, <snow.pcx>;
var snow_pos;

action snowfall
{
   my.invisible = on;
   while(1)
   {
       snow_pos.x = my.x + random(256) - 128;
       snow_pos.y = my.y + random(256) - 128;
       snow_pos.z = my.z;
       if (random(1) > 0.8)
       {
           emit(2,snow_pos,particle_snow);
       }
       wait (1);
   }
}

function particle_snow()
{
   if(my_age == 0)
   {  
       my_speed.x = 0;
       my_speed.y = 0;
       my_speed.z = -2.5 + random(1); 
       my_size = 128 + random(64);
       my_map = snow_map;
       my_flare = on;
       my_alpha = 32;
   }
   if(my_age > 128)
   {
       my_action = null;
   }
}

As you may have seen this code needs a picture (PCX) of a snow flake.

Open any photo/paint editing program and create a new file size 32 X 32

Fill it with pure black. Now make a snowflake in it your way and save it into your work folder as snow.pcx

It may look like this:
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Now open your level in WED.

We are going to make the object that drops snow in visible so it doesn’t matter which object we use. Import the lamp entity. Place it above the level in the sky and give it the snow action. Select invisible.

Build and run and see the snow falls down. Just copy the lamp more times so it

snows in the whole level. BRRRRRRRRRRRRRR cold.

It should look like this:
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4.4 Use ammo:

Copy mypanels and the war4 wdl files into your work folder.

Open your main wdl in notepad.

Find this line : 
<include war.wdl>;
Delete this line. Now under the includes add these two lines :

include <mypanels.wdl>;

include <war4.wdl>;

We just told our main wdl to use external wdl scripts to show the ammo and score stuff.

Now add this line at the bottom of your wdl

show_panels2();

This is calling the panels for score/ammo

Save it.

Build and run you level.  In the lower left corner you will see 2 digits both on zero

We are going to change that.

It should look like this:
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Every time you kill an enemy (Robot2 action), it will give you 100 points. You can change this by looking into the war4.wdl. 

Search for this line : show_score += 100;

We still have limitless bullets so we are going to change this.

Change you bubble gun action from logen into gun action otherwise it won’t work

Right click the bubblegun and change skill 4 into 2.25
Rightclick the ammo model and change skill 4 into 2
Build and run. Pick up the gun, shoot until its empty now get the ammo pack and see you get your ammo.

4.5 Make a menu bar:
Creating menubars are really not as hard as you think, just a little coding and a few bmaps, and you have it. We are now going to create a basic menubar with this easy step-by-step tutorial.

4.5.1 Menubar background

 First, we need a 640x480 px menubar background, as we have created for you here:
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Now that we have the background bitmap, lets make it visible on the screen when we starts the game. 

4.5.2 Making the menubar visible 

Copy game-scratch.zip file to the directory where the sphered level is yet. Now, lets make the menubar become visible when we starts the level. Open the sphere.wdl (in notepad) and paste this at the top of the wdl file:

bmap menu_backg <introscreen.bmp>; // this is the menubar background

panel menubar_pan

{

bmap menu_backg; // the background bitmap to be used for this panel (introscreen.bmp)

FLAGS D3D, refresh;

}

Place this at the bottom of the function main:

Menubar_pan.visible = ON;

Save your wdl file as sphered.wdl, and run your level. If you`ve done everething right, the introscreen.bmp should pop-up on your screen when you start the level.

4.5.3 Buttons

Ok, the menubar pop`s up now, but nothing happends when i click the buttons! So, now lets make the buttons. We need two bmaps that are going to button, one while the mouse is over the button, and one while it isn`t.
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   while not over
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   while over

Paste this code at the top of the sphered.wdl file:

Bmap button1 <button1.bmp>; // while the mouse is not over the button bmap

Bmap button2 <button2.bmp>; // while the mouse is over the button bmap

Now, insert this code inside the panel menubar_pan code:

button 10, 113, button2, button1, button2, NULL, NULL, NULL; //the start button

button 50, 200, button2, button1, button2, NULL, NULL, NULL; //the quit button

button 105, 284, button2, button1, button2, NULL, NULL, NULL; //the credits button

your code should look something like this now:

Bmap button1 <button1.bmp>; // while the mouse is not over the button bmap

Bmap button2 <button2.bmp>; // while the mouse is over the button bmap

bmap menu_backg <introscreen.bmp>; // this is the menubar background

panel menubar_pan

{

bmap menu_backg; // the background bitmap to be used for this panel (introscreen.bmp)

button 10, 113, button2, button1, button2, NULL, NULL, NULL; //the start button

button 50, 200, button2, button1, button2, NULL, NULL, NULL; //the quit button

button 105, 284, button2, button1, button2, NULL, NULL, NULL; //the credits button

FLAGS D3D, refresh;

}

We have now added buttons to the panel, this is how the button code is build up:

(button pos_x, pos_y, while the button are pressed down, while the mouse is not over the button bmap, while the mouse is over the button bmap, action when clicks the button, release over button action, while over button action)

Save your wdl script, and run the level again. Woho, the buttons work(
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The buttons are added, but nothing happends when i click on them! Now we are going to make something happen when we click on them.

4.5.4 The start button

To make the level start when we click the start button, we need to replace NULL at the action when clicks the button with an function, so replace the start button with this:

button 10, 113, button2, button1, button2, start_game, NULL, NULL; //the start button

Now we need to make the start_game function that makes the menubar invisible. Insert this function at the bottom of your wdl file:

function start_game

{

menubar.visible = OFF; // makes the menubar panel invisible

}

Save the sphered.wdl file, and run your level. When you click the start button, the menubar should get invisible.

4.5.5 The quit button

To make the game quit when we click the quit button, we need to replace the NULL at the action when clicks the button with an function, so replace the quit button with this:
button 50, 200, button2, button1, button2, quit_game, NULL, NULL; //the quit button

Now we need to make the quit_game function that exit the game. Insert this function at the bottom of your wdl file

function quit_game

{

exit;

}

Save the sphered.wdl file, and run your level. When you click the quit button, the game should quit.

4.5.6 The credits button
To make a credits panel get visible when you click the credits button, we need to replace the NULL at the action when clicks the button with an function and make the credits panel, so first paste this after all the bmaps your wdl file:

bmap credits <credits.bmp>; // the credits bitmap

panel credits_pan

{

bmap credits; // the bitmap background for credits is credits.bmp

button 83, 413, button2, button1, button2, show_menubar, NULL, NULL; //this 
//is the back button

FLAGS D3D, REFRESH;

}

Then we need to make the show_menubar function for the back button, that makes the menubar visible again, so paste this at the bottom of your wdl file:

function show_menubar

{

credits_pan.VISIBLE = OFF; // makes the credits panel invisible

menubar_pan.VISIBLE = ON; // makes the menubar panel visible

}

Now that we have the credits panel ready, replace the credits button in the menubar_pan with this:

button 105, 284, button2, button1, button2, show_credits, NULL, NULL; //the credits 
Now, insert this code at the bottom of your wdl file:

Function show_credits

{

credits_pan.VISIBLE = ON; // makes the credits panel visible

menubar_pan.VISIBLE = OFF; // makes the menubar panel invisible

}

The top of your wdl should look something like this now:

Bmap button1 <button1.bmp>; // while the mouse is not over the button bmap

Bmap button2 <button2.bmp>; // while the mouse is over the button bmap

bmap menu_backg <introscreen.bmp>; // this is the menubar background

bmap credits <credits.bmp>; // the credits bitmap

panel credits_pan

{

bmap credits; // the bitmap background for credits is credits.bmp

button 83, 413, button2, button1, button2, show_menubar, NULL, NULL; //this 
//is the back button

FLAGS D3D, REFRESH;

}

panel menubar_pan

{

bmap menu_backg; // the background bitmap to be used for this panel (introscreen.bmp)

button 10, 113, button2, button1, button2, start_game, NULL, NULL; //the start button

button 50, 200, button2, button1, button2, quit_game, NULL, NULL; //the quit button

button 105, 284, button2, button1, button2, show_credits, NULL, NULL; //the credits 

FLAGS D3D, refresh;

}

The bottom of your wdl should look something like this now:

function start_game

{

menubar_pan.visible = OFF; // makes the menubar panel invisible

}

function quit_game

{

exit;

}

function show_menubar

{

credits_pan.VISIBLE = OFF; // makes the credits panel invisible

menubar_pan.VISIBLE = ON; // makes the menubar panel visible

}

Function show_credits

{

credits_pan.VISIBLE = ON; // makes the credits panel visible

menubar_pan.VISIBLE = OFF; // makes the menubar panel invisible

}

Save your wdl, and run the level. If you`ve done everething right, you should get to the credits panel by clicking the credits button, and get back to the menubar when you click the back button.
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4.5.7 Adding sound

Maybe you want to add some background music to the menubar? Copy the spyvsspy midi file to the folder your level are in, and add this code to the top of your wdl file:

music menu_mid <spyvsspy.mid>;

now, add this to the button of function main:

midi_vol = 100; // sets the music volume to 100(/100)

PLAY_SONG spyvsspy, 100; // playes the song until you stop it

Save the wdl, and run the level. Some music should play when you starts the level now.

4.5.8 Returning to menu
When you click esc when you have started your level, the template menubar pop`s up, but we want our menubar to pop up! Add this to the bottom of your wdl:

ON_ESC show_menubar;

Save the wdl and run your level. When you click play and then esc button again, you should return to the menu.
5 More details for your game

In this section, we will discuss:
1) Your opening screen.

2) Using the start position
3) Make it snow
4) Adding sounds to objects
5) Restart the game when your dead
6) Changing the comment when you pick up a gun
7) Making Spiderman with a gun out of an existing model.

8) Creating a sky
9) Create the weather (snow,rain,hail)

10) Make things explode
5.1 Your opening screen
- Open the office2.wdl file in notepad. 
- Search the line that says: bmap splashmap = <logodark.bmp>; // the default A5 logo in templates
- Don’t make any changes it shows only that it uses the picture logodark.bmp which is in the template map.
- Close notepad and open logodark.bmp in any paint program.
- Add your own picture and text and save it again as logodark.bmp in the template map.
- Open 3d GameStudio, File- Map properties, and open the script you called office2.wdl
- Now build and run level.
- The game will start with your opening screen. Easy isn’t it?

This is a simple example. If you want to add your own pictures, make
sure it is saved in the template map and that the name is called in the wdl instead of logodark.bmp
5.2 Using the start position
- You can add a start position by clicking object; add position
- Now you will see a camera. Place it in your level (without entities) and point it the way you want it
- Build level
- you can walk through the level and you begin where you placed the 
 camera

This way it’s easy to make a virtual gallery where you can walk through.
The start position is also used to change the view of your entity.
5.3 Your first real assignment
- Go to wbwilson's web page and download the complete idiot's guide to AI. 
- Make a new file in notepad to put the code into call it "enemies.wdl"
- Save it to your work folder
- Find a wav sound to rename "killer.wav" and put it in the work folder
- Now you will need a model to fight you with the gun in place. I recommend the Held model from the  
  first Mission game. He's the easiest. Move him to the work folder also.
- Open the model in MED and use "select vertice" to find the vertex that you want him to shoot from.
  Highlight it and the vertex number should show up on the bottom menu.
- In the enemies.wdl for killbot you will see where to type in the the new muzzle vertex.
- Make a new level and name it test (one room one entity one lamb to shoot with
- Open your test.wdl and at the bottom of the script type this in:
 include <enemies.wdl>;
- Open your test now in WED and add the Held model and assign him the killbot action. He should now be hard to kill.

Now try to make more out of it.

Make some more killbots (killbot1, killbot2, etc.) only give them new sounds and different amounts of armor and health from weakest to boss enemy.  Just copy and paste the killbot code and name them killbot1 and killbot2.

Are we programming already? Yes, at this point it must be clear to you that adding the line <include...wdl> to your main wdl file combines all kinds of wdls together.
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5.4 Your second real assignment
To test new effects try the following FIREMODE with your weapon: 

// MY._FIREMODE = DAMAGE_SHOOT + HIT_FLASH       + HIT_HOLE + 0.50
// + HIT_SMOKE + HIT_SPARKS + 0.50
// + FIRE_LASER + GUNFX_BRASS + 0.50; 

(These are all right out of the templates and many thanks to Doug, also a forum user) 
Now here's your assignment for your own learning experience: 
1) Try the above firemodes on 3 of your robots by changing their scripts.
2) Now make about 5 more robots (use the control key and drag out from one of your existing bots).
3) Try using the number combinations from the weapons.wdl (open up the weapons wdl and print it out so you can see what numbers you combine) So a rocket launching robot would have a firemode that looks like this: 

MY._FIREMODE = 16; 

There is an EASIER way to do this if you DON'T want to script each bot is take the one bot you have and assign this firemode in the SKILL8 slot in the properties. But this should give you a good start on adding variety to your enemies. Also try the damage points after a decimal in that slot. 

FOR EXTRA FUN (and it may even entice you to try JCL's wdl in seven days). Open the tutorial that comes with the game (not the online one but the “learn it in seven days” one). Find the robot enemy you are supposed to make and copy the firemode script for it to YOUR robot. This makes a truly vicious enemy that is very tough. A couple of shots from him with the fireball and you are dead. (Hint: it’s in the Wednesday part in the 7-day tutorial...) 

The numbers in the skill8 is the simplest way to add weapon variety to your robots. The most certain method though is to go in and change their scripts using the firemode scripts.
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5.5 Make it snow
- First download the snow.wdl and the snow.pcx  (you can find it in the  
 downloads section). Save it to your work map.
- Now make a room build it and save it as snowfalls
- Now change map properties, new, it will be called snowfalls now.
- Again save it
- Open up the snowfalls WDL and add the next line at the end of it:


  include <snow.wdl>;

  Yes you’re right we added the snow wdl to our main wdl.
  Save it.
- Open your level and add an entity it doesn't mind what kind of because
  we’re going to make it invisible. We only need it to drop snow.
- Add the action snowfall, Make sure invisible is selected.
- Now drag the entity to the roof of you room.
- Build and run and wow it's snowing
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5.6 Adding sounds to objects
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- Make a room with one entity and a cylinder 6 sided
- Now add the texture water to the cylinder
- Click object add sound and choose water.wav
- You will see a sound icon appear in your screen (Red coneshape) 
- Place it on the cylinder
- Save your level as water
- Build and run
- When you walk to the water the closer you get the better you hear the 
 sound of water running.

5.7 Restart the game when the hero dies
- Make a copy of the war.wdl and call it war2.wdl
- Delete the war.wdl in the script file and include the war2.wdl
   just type this at the end of your script.  include <war2.wdl>; 
- In the player_fight portion of war2.wdl modify it so it looks like this:
  
function player_fight()
{

if(MY._HEALTH == 0) { MY._HEALTH = 100; }

MY.ENABLE_SCAN = ON;
MY.ENABLE_SHOOT = ON;
MY.EVENT = fight_event;

while(MY._HEALTH > 0)
{
 if(MY._SIGNAL == _DETECTED) { // Hit received?
  MY._SIGNAL = 0; // reset the _signal skill
  if(person_3rd == 0) {
   player_shake(); }
 }
 wait(1);
}

// Dead
MY._HEALTH = 0;
if(person_3rd == 0)
{ // 1st person die action
 
MY._MOVEMODE = 0;  // don't move anymore
 
MY.EVENT = NULL;  // prevent health counting down
 
player_tip();
 
waitt(8);
 
weapon_remove();  // let weapon disappear
 
wait (80);//change this to vary the time//////
 
load_level(<monitor.WMB>);///////////////////change monitor into your level name
}
else
{
 
weapon_remove(); // prevent dead player firing
 
BRANCH state_die;
}

Now build and run. When you die the level starts all over again..
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5.8 Changing the comment when you pick up a gun
- In the weapons.wdl you will see some strings for gun pickup:
 STRING got_gun1_str,"Got a small gun!";
- Just change this and add it to the bottom of your wdl script:
(STRING got_gun1_str,"Ready to do some killing?" 
- Now include this into your game and when you pick up the gun 
 the line will appear.
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5.9 Making Spiderman with a gun out of an existing model
- Open 3DGS modeling program.
- Open up the model HELD from the mission 1 game
- Click View skins
- You'll see the texture of the model (Picture 1.)
- Click  File, Export, BMP; save it as test.bmp
- Now open test bmp up in any photo editing program.   
 (even windows paint will do)
- Now paint over the texture your own design. (pic 2,)
- When your finished save it as test2.bmp
- Open 3DGS modeling program.
- Open up the model HELD from the mission 1 game
- Click View skins
- Click file import and open your test2.bmp 
- Click edit, add new skin
- In the modeller, your model is shown (Pic 3.)
- Now save your model with a new name like Spidey with a gun.
- For more examples go to the download section
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5.10 Creating a sky
- Create a room.
- Use the scope function to remove the top (Roof).
- No add a cube that’s bigger than your room.
- Ad a sky texture to the cube.
- Now build your level and see the sky outside.
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5.11 Create the weather (Snow,rain,hail)

- Download snowmap and snow pcx from the download section
- Now open the Snow pcx in any photo editor.
- Change the picture into a red and yellow mixture
- Save it into your work folder as fire.pcx
- Now open with notepad the snow wdl.
- Change all the word snow into fire and save it as fire.wdl
- Include the fire wdl into your main wdl
- Give an object the firefall action and make it invisible.
- Build and run the level and see fire is falling from the sky

You can create all kinds of weather this way or make soap bubbles falling from the sky.
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5.12 Making things explode
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- Download the exploder.wdl from the  download section
- Just make sure you include it in your main WDL
- Now select an object and give it the exloder action
- Build and run.
- When you shoot the object the object explodes

It can kill you, so don’t get too close, but make sure the enemies are nearby.
6 Elevators, special effects, talking entities, MORE!

1) Create elevators the right way.

2) Fire sparks.

3) Make an entity speaking to you.

4) Add, create your own textures. WADS

5) Make a building with your own textures.

6) Easy panel creation.
Create terrains with BRYCE.

6.1 Create elevators the right way
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- Start a new file in WED save it as "lift2.wmp"
- make your model in WED out of an eight-sided cylinder and CSG subtract    the place where the guy stands -
- texture the whole thing with "heavymetal"
- scope down and you can start texturing the inside with "wood"
- add a couple of lights
- adjust the up and down distance so the platform of the model is     just          beneath the horizontal "0" axis in WED (thick line)
- build as a "map entity"
- go back to your main level and go to object "place map-entity"
- assign it the elevator action and the height you need 
  to go (from  WED) in the Skill3 slot
6.2 Fire sparks

Remember the snow tutorial ? This works the same so try it out on your own.

You can download the firesparks.zip from the download section.
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6.3 Make an entity that speaks to you

- We’re going to add a code to let an entity speak to you when you get Close to it.
- Add the following code at the end of your WDL

SOUND whammy <nothing.wav>;//instead of nothing enter your wave file name.//
/////////////nothing
function speech_event()
{

IF (YOU == PLAYER)
{

MY.EVENT = NULL;
PLAY_SOUND, whammy, 70;
WAIT 1;

}
}

ACTION detect_entity
{

MY.ENABLE_TRIGGER = ON;
MY.TRIGGER_RANGE = 400; // talk range
MY.EVENT = speech_event;

}

-    Save it
-    Open up your level and add an object or entity.
-    Give it the Detect_entity action (This code we just inserted in the wdl)
-    Build and run. When you get close to the object or entity. Iit will speak out your 
      wave file
-    MY.EVENT = NULL; plays the line only once. If you delete this line the sound will repeat continuously.
6.4 Add, Create your own textures & WADS
Wads use bmp and pcx formats. 

- The best size is 128X128
- So convert your jpg to bmp or pcx with any paint program.
- Now open wed.
- Click texture > texture manager
- Click build wad so there is a name for your wad collection.
- Now add wad and choose yours.
- With your wad selected click edit wad
- Now you can add your bmp and pcx textures to it. 
- Save it and your ready to use your new texture
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6.5 Make a building with your own textures
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Open in any paint program a picture of a building.
- Now take out the peaces you would like to use (1)
- Best size for texture is 128 X 128 It has to be in pcx or bmp format.
- Make sure youre texure is mirrored at the half of it so there
  wont be any lines interfering with your texture. (2)
- Open Med click new. Click texture > Texture manager.
- Click build wad. Now give your wad a name.
- Click edit wad, and add your own textures to it, Then save it (3)
- Now create some cubes scale them and texture them with 
  your made textures.
- Build your level to see if your texture is fit right. It's taking a 
  while and is a bit puzzling but at the end you can create a
  nice looking building (4,5,6)

If you like the textures I used you can download them 
from the download section under the name building.wad;
It's free to use.
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6.6 Easy panel creation
- Create a panel in any paint program. (1)
- Make sure the size is 640 X 480
- Use pure black on those part you want to make transparant.
- Now save it into your workfolder as test.bmp
- Add this to the top of  your wdl, after the includes;
/////////////////////////

BMAP test_map <test.bmp>;

PANEL test_panel
{

BMAP test_map;
LAYER 2;
FLAGS OVERLAY, REFRESH, VISIBLE;

}

- Then add this line to your main wdl:


test_panel.visible = on;

- Now build and run and your panel is in the game

You just have to make sure that the window in the middle is 0,0,0 RGB or pure black to be transparent and that it is the 800 x 600 size you need and any of the other "blacks" are lighter (like 5,5,5).
6.7 Add a second panel



- Copy the code and change the bmp file into your bmp file name;
  in my case it’s spawn.bmp
- Change all the word test into something else, Let's say doh.
- Build and run and you have 2 panels active. (3)
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6.8 Create terrains with BRYCE
Download the tutorial. it's in html format.
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7 More extras…

1) Text appears when player touches an object.



2) Easy creating a flame thrower.

3) Use your own fonts for score ammo health numbers or txt.

4) Creating your own healthbar (Horizontal.)

5) Create Underwater bubbles going up.

6) Make a gun shoot from the right position.

7) Hanging up some cool pictures.

8) Easy gun modeling with 3d studio max.

9) Text and panel appears when player touches object.

7.1 Text appears when player touches an object
WDL CODE WHEN PLAYER TOUCH OBJECT TEXT APPEARS
It took a while to figure it out but it works just fine.
Ad the following lines at the bottom of your main WDL

string textap_str = "Don’t touch the guard dude !"; 
function text()
{
msg.string = textap_str;
show_message();
wait(1); // time for message to become visible

} 

ACTION Show_text 
{ 

SET MY.ENABLE_IMPACT, ON; 
SET MY.EVENT text;

} 

Now give an object or entity the show_text function.
When the player touches the object or entity the text
don’t touch the guard dude ! will appear.
You can insert many more text codes by duplicating the code 
and change it like this


string textap1_str = "Don’t mind  !"; 
function text2()
{
msg.string = textap1_str;
show_message();
wait(1); // time for message to become visible
} 
ACTION Show_text2 { 
SET MY.ENABLE_IMPACT, ON; 
SET MY.EVENT text2;
} 

If you give an other object the show_text2 action when it's touched it will give the text don’t mind!
TIP: if you want to change the message sound jut replace MSG.wav
7.2 Creating an easy flame thrower

Open the following pictures in any paint program.
- Blitz.PCX
- explo+7.PCX
- Particle.PCX
- Fball.PCX
You can find them in the template folder.
Now edit this pictures so  they get a fire look. (look at examples)
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Save it all under their original names and formats.

· Open your level and give the flamethrower the gun action.
- Select flag 7. Why ? Well it give the gun unlimited bullets an    
 shoots automatic. So it looks lake a splash of fire.
- Put skill 8 on 18.8 this is giving the fire effect. Check your  
  Weapon wdl
 Build and run...
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7.3 Use your own fonts for score ammo health numbers or text
This is a simple way of doing this when you use the wdl templates It's using the digifont.pcx and were gonna replace it the easyway.

- Download the a4 font generator (great program)
  Its on 3dgs links site.
- Now create a font. It's explained in the help function.
- For pallete choose the digifont.pcx
- Open your font that you just made in any paint program
- Convert it to true colour 24bit
- Resize it to : 384 X 64
- Save it as digifont.pcx in the template folder (replace the    
  original)
- Rename your original digifont.pcx so you have it backed up.
- Now build your level with the score wdl active and see your font

Tip ! When you resize the font it will come out very small so use the biggest size when you generate one. If you can use BOLD to make it look better.
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7.4 Creating your own healthbar (Horizontal)

Put the following code in your main WDL:

bmap health_map = <health.pcx>; 
panel hbar_pan 
{ 

hbar 20, 20, 230, health_map, 1, player._health;

   flags = refresh, visible, overlay; 

}


This code is going to show the healthbar, and every time you’re  hit it's becoming smaller untill there is nothing left. And then...you’re dead.

You can easy make your own healthbar; just save it as health.pcx in your work folder.
7.5 Water bubbles
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Paste this code into your main wdl and give an object the  bubbles action make it invisible.
Make sure you have a bub.pcx in your workfolder.

//underwaterbubbles by Marty bee//realspawn////

bmap bub_map, <bub.pcx>;//
var bub_pos;

action bubbles
{

my.invisible = on;
while(1)
{

bub_pos.x = my.x + random(200) - 100;
bub_pos.y = my.y + random(200) - 100;
bub_pos.z = my.z;
if (random(1) > 0.7) // play with this value
{

emit(2,bub_pos,particle_bub);

}

wait (1);
}

}

function particle_bub()
{

if(my_age == 0)
{ 

my_speed.x = 0;
my_speed.y = 0;
my_speed.z = 2.5 + random(1); //this makes it fall "upwards"
my_size = 100 + random(50);
my_map = bub_map;//you need a bubble
my_flare = on;
my_alpha = 30;

}
if(my_age > 250)

{

my_action = null;
}
} 
7.6 Enemy fire

(Make the enemy shoot from the right position where the bullets come out)

I used my toy tank as an example.

-  Open the Toy tank in MED.
-  Choose select by vertex, then pick a vertex on his gun
    you want the bullet to eminate from. The vertex will have a
    number that shows up in the bottom menubar.
-  Remember this number.
- Now open with notepad the war.wdl
- Find the robot2 action and ad this line :

  MY.MUZZLE_VERT = 111;//replace with your number

- save it run the level and the toy tank fires from the right 
   spot now.
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7.7 Hang a cool picture on the wall

Make sure your picture is an PCX file and save it into your work folder.

- Select the object menu.
- Select Insert Entity.
- Change the file format type to "PCX Picture Files".-
- Now the image will be loaded as a sprite image.
- Right-click on the new object and for the angle settings make each property "-1". If you do not do this the sprite will follow the screen. Give it a go with and without -1 in each angle  property box.
-Then you can position and rotate the object in the WED editor
 without any dificulty. 

Credits to :
Lea Hayes 

Set its pan on 1 so it wont rotate for sure
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7.8 Easy gun modeling with 3d studio max

Step one :

- Open 3D Studio Max.
- Select the Frontviewport
- Click Views > Viewportbackground
- Load an  image of a gun it should look like this >>
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Step 2 :

- Select splines
- Draw a line around the gun so you create the shape.
- Click > Ad modifier > Bevel
- On the parameter bar set level 1 Height to 14.0
- NOW YOU GOT YOUR GUN
Step 3 :

- You can smooth the model anyway you like.
- Export the gun as 3DS file.
- Open MED and import your gun scale it.
- Now skin it the way you want you can even use the 
 original picture to texture it.
- Save it. and you made a gun in 3 easy steps
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