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What Is LyX?

LyX is document processor that works as a front end to IXTEX. It
allows for instant previewing of the document from the input side of the
process, creating a near WYSIWYG version of INTEX, coined by LyX
users as WYSIWYM.

We’ll overview three of the common document classes:
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Q Article

© Letter

© Beamer
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Article is the default document class when IxX is first opened. The
structure of sections, titles, and lists within the document works the
same as in IXTEX, but are entered differently. This will be explained in
the next slide. These “paragraph styles” are refered to, in IyX, as
environments. Article allows for other typical scientific document
environments such as tables, figures, math expressions, etc.
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Sections are very straightforward.
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Article

Sections, Titles, and Lists

Sections are very straightforward.

o Click the cursor to the desired line in the document

e Click the Environment dropbox (the leftmost element on the
buttonbar)
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Article

Sections, Titles, and Lists

Sections are very straightforward.

o Click the cursor to the desired line in the document

e Click the Environment dropbox (the leftmost element on the
buttonbar)

@ Select Section, Subsection, Subsubsection, Paragraph, or
Subparagraph
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Article

Sections, Titles, and Lists

Sections are very straightforward.

o Click the cursor to the desired line in the document

e Click the Environment dropbox (the leftmost element on the
buttonbar)

@ Select Section, Subsection, Subsubsection, Paragraph, or
Subparagraph

This automatically makes the selected line into the desired
environment. Using this same method, a selected line can be made into
an unnumbered section (Section*), Title, Author, Enumerate list, Itemize
list, etc. All these environments are selectable in the dropbox.
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Article

Sections, Titles, and Lists

\My Documents\newfile3.lyx (changed)
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Lyx_Presentaton™ Extended newfies™ nenfie?

e Using LyX for the First Time

Sibsecton
Sibabsecton
Sibparagrach Robert Thetford, Jr.
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Secton®
Subsection”
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aragraph’
Subparagraph

Author Abstract
Oate

jges  bisis my first LyX document and I am using it to demonstrate how to perform simple LaTeX typseting tasks with the LyX interface.
e

1 Introduction,

This is an introduction to my first LyX document.

2 Math

How to show arithmatic and equations, or “math formalae™

Font: Default
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Article

Tables

Tables are very straightforward.

@ Click the cursor to the desired line in the document
o Create a new table with Insert> Table
@ Specify how many columns and rows

o Click each and edit each individual cell
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Article

Tables

Tables are very straightforward.

@ Click the cursor to the desired line in the document

o Create a new table with Insert> Table

Specify how many columns and rows

Click each and edit each individual cell

o Use the Table Toolbar (shows at bottom of screen when inserted
table is left-clicked) to toggle borderlines and designate
multicolumns (multirows not supported by LyX)

Robert Thetford, Jr. () IyX: The WYSIWYM Document Pro July 9, 2010



Article

Tables

Tables are very straightforward.

@ Click the cursor to the desired line in the document

o Create a new table with Insert> Table

Specify how many columns and rows

Click each and edit each individual cell

o Use the Table Toolbar (shows at bottom of screen when inserted
table is left-clicked) to toggle borderlines and designate
multicolumns (multirows not supported by LyX)
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Tables

| Lyx: -\My Documents\newfile3.lyx (chan |- [=]x]
st MOASRY THEX I BRGENYEE eRE
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newfie® 3 | Tutorl® UserGuide LyX Presentaton® Extended newfies® nenfie?
2. The Lord of the Rings Trilogy

3. Star Wars
Descriptions:

hostile warlike; unfriendly

LyX: Insert Table.

Attila_the Hun king of the Huns; the most successful barbarian in

List Conjunction of things
4 Tables

Multicolumn | 1

2 [3[ 4 s
5 Graphics

Click Ref: Figure 1 to go to Figure 1.

(t3bular-nsert)
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Figures are very straightforward. In [yX, they are refered to as
graphics.
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Figures

Figures are very straightforward. In [yX, they are refered to as
graphics.

@ Click the cursor to the desired line in the document

o Create a new graphic with Insertr> Graphics
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Article

Figures

Figures are very straightforward. In [yX, they are refered to as
graphics.

@ Click the cursor to the desired line in the document
o Create a new graphic with Insertr> Graphics

e Specify an image to insert (all known image formats will work)
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Article

Figures

Figures are very straightforward. In [yX, they are refered to as
graphics.

@ Click the cursor to the desired line in the document
o Create a new graphic with Insertr> Graphics
e Specify an image to insert (all known image formats will work)

e Optional: Specify a scale percentage, scale by width, or scale by
height value
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Article

Figures

Figures are very straightforward. In [yX, they are refered to as
graphics.

@ Click the cursor to the desired line in the document
o Create a new graphic with Insertr> Graphics
e Specify an image to insert (all known image formats will work)

e Optional: Specify a scale percentage, scale by width, or scale by
height value
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Article

Figure

[ Lyx: ~\My Documents

st VNS BYTHEX L BRS ER2EE e@EE
VBT E |EFEBENYS abSEW

QrABA

newfie3” 3 | Tutoral® UserGude LyX Presentaton® Extended newfies® renfie7
While in the standard text environment, math shows up just like any other [EVeePI= (@3] 4
To enter an inline LaTeX typeset equation Graphics | Cippng | LaTeX and LyX options.

1. Select where in the doument you would like the equation Fie: [myspoonsbig.ong

2. Click the Insert Math button
3. Enter LaTeX math commands or LyX shorthand commands Set width: Cl an v
4. HitEsc to end the equation e

Rotate Graphics

Angle Degrees): [0 Orign: Defautt v

=

float: Figure Figure 1

Font: Default

2010
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Math is very straightforward.
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Article

Math

Math is very straightforward.

@ Inline Equations

o Click the cursor to the desired line in the document

o Create a new math formula with Insert>Math > Inline Formula
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Article

Math

Math is very straightforward.

@ Inline Equations

o Click the cursor to the desired line in the document
o Create a new math formula with Insert>Math > Inline Formula

o Enter BETEX math commands or IyX shorthand commands
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Article

Math

Math is very straightforward.

@ Inline Equations

o Click the cursor to the desired line in the document
o Create a new math formula with Insert>Math > Inline Formula
o Enter BETEX math commands or IyX shorthand commands

e Hit Esc to end the equation
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Article

Math

Math is very straightforward.

@ Inline Equations

o Click the cursor to the desired line in the document
o Create a new math formula with Insert>Math > Inline Formula
o Enter BETEX math commands or IyX shorthand commands

e Hit Esc to end the equation

Displayed Equations are quite similar:

@ Displayed Equations
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Math

Math is very straightforward.

@ Inline Equations

o Click the cursor to the desired line in the document
o Create a new math formula with Insert>Math > Inline Formula
o Enter BETEX math commands or IyX shorthand commands

e Hit Esc to end the equation

Displayed Equations are quite similar:

@ Displayed Equations

o Create a new math formula with Insert>Math > Display Formula
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Article

Math

Math is very straightforward.

@ Inline Equations

o Click the cursor to the desired line in the document
o Create a new math formula with Insert>Math > Inline Formula
o Enter BETEX math commands or IyX shorthand commands

e Hit Esc to end the equation

Displayed Equations are quite similar:

@ Displayed Equations
o Create a new math formula with Insertt>Math > Display Formula

e Give the equation a number label with Edit>Math>Number Whole
Formula (for a single line equation)
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newfies* ) | Tutorial® UserGuide. LyX_Presentation™ Extended newfies* newfie?

Example:  E=mc"2 becomes E = mc’¢

\ly-Ax\['2 + \alpha \Lx\/"2 becomes |y - 4x||% + a || Lx||>
To enter a displayed LaTeX typeset equation

1. Select location in document with cursor

2. Click Insert Math button

3. Click Display button in the Math Toolbar

4. Enter LaTeX math commands or LyX shorthand commands

5. Hit Esc to end the equation

+ Note: To mumber a displayed equation, select equation and click Toggle Numbering of Line under the Math menu. Similarly, to label the
equation, select it, and click Label under the Insert menu.

1+1=2 #)

2.2 Subsection descrintion ¥
W EMBEA SV o« -t €S 2. b F

TLPEEFE N 000N EEERS®Y|X

Trpe: simple
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LyX allows for a simple but professional looking Letter document.
Letter can be written from scratch just like Article, except that there are
different environments available. However, an advantage to using LyX
is that there are some templates available to make creating documents
even easier. One template included with LyX is a Letter template.
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Letter

Template

\My Documents\newfile7.lyx
Fle Edt Vew Insert Navgate Doment Tods Heb

wades VOB RIY T DS B¢
= kW@ e

$EpmraE ¢eHE
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;AER
nenfies Tutoria” Userude X presentaton” Extended nenfies nevie? @
[eMy Name><
<My Street>¢

<My Town>

<Send To Name> ¢
<Send To Street> ¢
<Send To Town>

Red fields are mandatory, green ones optional.

Signature: <Your signature >

Opening: <Dear ..>
<Text of Your Letter. To create a real letter, just replace erase all the text in <> (including the “<>" characters) with the desired text.>

Closing: <Yours sincerely,>
ce: <cc>
encl: <encl>

Telephone: <number> &

Figure: Letter Template
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Beamer

Beamer is the slide presentation document class. From a TEX user
standpoint, the input process in IyX for a Beamer document is a little
odd at first, but simple after repeated use. Like Article and Letter, all
the document class specific environments can be found in the
Environment dropbox. The following screenshot is for the second frame

of this presentation.

22
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Beamer

Example

_Presentation.lyx (changed)
Fle Edt Vew Insert Navgate Document Tods Heb

fndFrame VOIS ESE DO &S BRe Etmze=s ¢EE
kW@ e
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newfie3* Tutorial® UserGuide LyX Presentation” () | Extended newfies® newfie7

Section 1 What is LyX?

Frame What Is LyX?

\ setbeamercovered{dynamic}

LyX is document processor that works as a front end to LaTeX. It allows for instant previewing of the document from the input side of the process, creating
anear WYSIWYG version of LaTeX, coined by LyX users as WYSIWYM.
We'll overview three of the common document classes:

1. Article
2. Letter

3. Beamer

Font: Default
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Conclusion

In conclusion, IyX is simple and hard?
e Creating documents that work within the default parameters is
very simple.
o Creating documents that require much fine tuning or more
complex elements is difficult.

Questions?

Robert Thetford, Jr. () IyX: The WYSIWYM Document Pro July 9, 2010



	What is L.25emYX?
	Article
	Sections, Titles, and Lists
	Tables
	Figures
	Math

	Letter
	Template

	Beamer
	Example

	Conclusion

