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Setup for NCSU/UofU ami06
 .bashrc environment variables

# Set up NCSU-CDK and Univ. of Utah Support

export CDK_DIR=/class/ELEC6250/ncsu-cdk-1.6.0.beta

export SYSTEM_CDS_LIB_DIR=/home/nelson/nelsovp

export CDS_NETLISTING_MODE=Analog

# Create alias for Global Foundries BICMOS8HP Digital Kit

export CMOS8HP=/class/ELEC6250/cmos8hp/std_cell/v.20130404

export BICMOS8HP=/class/ELEC6250/IBM_PDK/bicmos8hp/relHP

export TECHDIR=/class/ELEC6250/IBM_PDK/bicmos8hp/relHP/Calibre

 From directory /class/ELEC6250/UofUtah
 Copy cdsinit to your home directory and name it .cdsinit

(this will load other initialization files)
 Copy cds.lib.auburn to your home directory or to your project directory

(or add lines from this file to your current cds.lib file)
Example on next slide.

Your home directory

BICMOS8HP
setup



cds.lib 
 Virtuoso loads cds.lib from the directory in which it is invoked

 cds.lib in my home directory has the “system library” definitions for the 
installed libraries (BICMOS8HP, NCSU, UofU, Cadence, etc.)

 cds.lib in my project directory references the above and then defines my 
own project-specific libraries:
 SOFTINCLUDE /home/nelson/nelsovp/cds.lib
 DEFINE UofU_tricounter

/home/nelson/nelsovp/cadence/Modulo6_UofU/top/UofU_tricounter
 DEFINE my_new_ami06 

/home/nelson/nelsovp/cadence/Modulo6_UofU/top/my_new_ami06
 DEFINE my_pads /home/nelson/nelsovp/cadence/Modulo6_UofU/top/UofU_Pads

Pads copied from UofU installation



NCSU Cadence Design Kit (CDK)
https://www.eda.ncsu.edu/wiki/NCSU_CDK 

 For analog/digital CMOS IC design via the MOSIS IC 
fabrication service  (www.mosis.org)
 Version ncsu-cdk-1.6.0.beta for Cadence Virtuoso 6.1 and later

 Supports all MOSIS processes based on SCMOS rules
 ami_06/16,  hp_04/06,  tsmc_02/03/04
 GDSII layer maps
 Diva DRC, LVS support (no PEX)
 Composer interfaces to HSPICE/Spectre, Verilog
 Technology-independent libraries for analog & digital parts
 Transistor models, layouts, etc.
 But – does not include standard cell layout library

 MOSIS wirebond pads (AMI 0.6μm,  TSMC 0.4 μm, HP 0.6μm)

Installed in    /class/ELEC6250/ncsu-cdk-1.6.0.beta



U. of Utah CDK (used in Dr. Brunvand’s book)

/class/ELEC6250/UofUtah/
 UofU_TechLib_ami06  UofU-modified tech library for AMI C5N 

0.5 micron CMOS process, in the NCSU CDK framework
(AMI acquired by ON Semiconductor for $915M in 2008)

 UofU_Digital_v1_2   Std. Cell library (37 cells, use M1 & M2)
 UofU_Digital_v1_2.db: compiled library file for Synopsys Design Compiler
 UofU_Digital_v1_2.lef: abstract layout information file for place and route tools
 UofU_Digital_v1_2.lib: library characterization file
 UofU_Digital_v1_2.v:Verilog interface and simulation behavior file 
 UofU_Digital_v1_2_behv.v:Verilog models with timing “specify” blocks

 UofU_Pads Pad cells and frames based on the MOSIS-supplied .5μm
pads from Tanner, but UofU-modified to pass DRC and LVS

 UofU_AnalogParts UofU-modified transistor models that add delay 
to the switch-level simulation of those devices



UofU_Digital_v1_2 CMOS cell library
 AND3X1: 3-input AND
 AOI21X1, AOI22X1:AND-OR-Invert gates
 BUFX2, BUFX4, BUFX8: non-inverting buffers
 DCBNX1, DCBX1, DCNX1, DCX1: D-type flip flops with active-low clear. 

B means that the device includes both Q and QB outputs. 
N means active-low clock.

 ENINVX1, ENINVX2: enabled (tri-state) inverters
 FILL, FILL2, FILL4, FILL8: filler cells of different widths for filling in std cell rows
 INVX1, INVX16, INVX2, INVX4, INVX8: inverters
 LCNX1, LCX1: level-sensitive (gated) latches with active-low clear. 

N means active-low gate
 MUX2NX1, MUX2X2: 2-way muxes. N means an inverting mux
 NAND2X1, NAND2X2, NAND3X1: NAND gates with 2 and 3 inputs
 NOR2X1, NOR2X2, NOR3X1: NOR gates with 2 and 3 inputs
 OAI21X1 OAI22X1: OR-AND-Invert gates
 TIEHI, TIELO: Cells used to tie inputs high or low
 XNOR2X1: 2-input XNOR
 XOR2X1: 2-input XOR

Xn = drive strength



UofU_Digital_v1_2 cell views

 cmos_sch – schematic of transistors from UofU_Analog_Parts library
 behavioral -Verilog with “specify” blocks for SDF simulation
 layout – full cell layout
 symbol – to use in gate-level schematics
 extracted – extracted from layout for LVS verification

Cells use UofU_TechLib_ami06 technology library



UofU_Pads

• Frame1_38 for MOSIS “TinyChip”  (38 signal pins, 2 power/ground pins)
• Layout and schematic views
• Edit properties to change pad type within the frame

• Power/ground: pad_vdd, pad_gnd
• Signal:             pad_in, pad_out, pad_io
• No connect:     pad_nc
• Corner:            pad_corner

Based on MOSIS-supplied .5μm pads from Tanner



UofU_Analog_Parts

 nmos/pmos 3-terminal (bulk to gnd!/vdd!)
 bi_nmos/bi_pmos bidirectional device
 r_nmos/r_pmos weak/resistive transistors
 vdd/gnd

Based on NCSU_Analog_Parts



BICMOS8HP/UofU differences
 Synthesis with Synopsys Design Compiler
 Setup file:  .synopsys_dc.setup
 Path to library: /class/ELEC6250/UofUtah
 Target library: UofU_Digital_v1_2.db

 Synthesis script references to specific library cells
 Example:  myInputBuf (cell driving inputs) 

Example: Synthesized Modulo-6 counter netlist



BICMOS8HP/UofU differences
 Block layout with Innovus
 Technology: 500 nm feature size (BICMOS8HP is 130 nm)
 Wires/spacing may have to be larger
 Special library cells (filler, clock buffer, etc.)
 LEF file:  UofU_Digital_v1_2.lef
 Power: vdd! Ground: gnd!
 Timing library: UofU_Digital_v1_2.lib   (no capacitance table)
 I/O pins and routing with only 3 metal layers:  M1 M2 M3
 Power planning nets:  vdd!  gnd!
 See later slide for exporting layout to Virtuoso

Example: Modulo-6 counter layout (next slide)



Innovus:
modulo6 in ami06 technology

3 metal
layers



Innovus: save cell for importing into Virtuoso

 Export DEF (Design Exchange Format) file:
 Menu: File > Save > DEF
 Command:
global dbgLefDefOutVersion
set dbgLefDefOutVersion 5.6
defOut -floorplan -netlist -routing $BASENAME.def

 Export Verilog structural netlist
 Menu: File > Save > Netlist

 Command: 
saveNetlist -phys -includePowerGround -excludeLeafCell ${BASENAME}_soc.v



Virtuoso CIW (Command Interpreter Window)

Cadence libraries and tools are accessed from the CIW

Import/Export designs
Access libraries



Library Manager

New library

New cell

Views created by import.
Double click to open with 
appropriate tool.

Library paths
in cds.lib



Import digital block into Virtuoso
 Create a new Cadence library for the cell
 Attach technology library UofU_TechLib_ami06

 Import DEF layout information into Virtuoso:  
 Innovus saved: mydesign.def
 Import into a the new Cadence library
 File > Import > DEF

 Results in cell “layout” view

 Import circuit netlist into Virtuoso:
 Gate-level netlist saved by Innovus: mydesign.v
 Import netlist into a Cadence Library
 File > Import > Verilog

 Results in cell “schematic” and “symbol” views



In Virtuoso CIW:
File > New > Library

My library name

Directory for library files

Attach to an existing library

Select UofU_TechLib_ami06



In Virtuoso CIW:
File > Import > DEF

DEF file from Innovus
My library for this cell

Name of top design cell
Cell view type

Technology library
(Contains std. cells & .lib/.lef/.v files)

my_new_ami06



In Virtuoso CIW:
File > Import > Verilog

My library for this cell
Reference tech libraries

Verilog file(s)

Create schematic
and symbol views

Verilog models of
the standard cells

(copy to your directory)

UofU_Digital_v1_2_behv.v



Schematic view of “modulo6”



Symbol view of “modulo6”



Layout view of “modulo6” 
Abstract view- no cell layout details



Verify the layout (DRC-Extract-LVS)
 First - change cellviews of instances from abstract to layout
 Tools > Find/Replace

Instances (inst)
Change view name from abstract

to layout

Click to add view name

Replace all



Layout view of “modulo6” 
Layout details now shown

To see all layers:

Options>Display

Display levels
Start 0
Stop 30



Design rule check to ensure correct layout

Verify > DRC

Design rules file

No violations!



Extract to prepare for LVS

Verify > Extract

Extraction rules file

“extracted” view added to cell



Perform layout vs schematic check
Verify > LVS

LVS rules file

Browse to select
schematic & extracted
cell views from library



Top-level bottom-up design process
 Generate block layouts and for each block:
 Create a Virtuoso library for each block
 Import DEF file and Verilog netlist
 Perform DRC-Extract-LVS on each block until “clean”

 Create a block diagram schematic in Virtuoso Schematic
 Create a library for the top-level block
 Create a schematic view
 Instantiate schematic symbols from the library
 Interconnect with nets and add pins
 Check and save

 Create a layout from the schematic diagram



Top-level block schematic in “Schematics XL”

Layout blocks



Creating the block diagram
 Library Manager: File > New > Library

(new library for the block diagram and its layout)
 Library Manger: 
 Select the new library 
 File > New > Cell View
 Fill in the form
 OK to open “Composer”



Drawing schematics
 Add instances:   
 Create > Instance
 Select cell from lib.
 Move cell to position
 Left click to place
 Repeat for more inst’s
 ESC to exit



Drawing schematics
 Add pins:   
 Create > Pin
 Enter name(s)
 Move cursor to position
 Left click to place first
 Repeat for each pin
 ESC to exit



Drawing schematics
 Add wires:   
 Create > Wire (narrow)
 Cursor to pin
 Left click to begin
 Cursor to other pin
 Left click to end

(Left click in between for “bends”)
 Add more wires.
 ESC (Cancel) when finished

 Create > Wire (wide) for buses
 Create > Wire Name to name a wire
 Check > Current Cellview to detect drawing errors
 File > Save (Schematic)  and Close



Individual wires from buses
• Buses inherit pin names

• Bus A<1:0> contains wires A<1> and A<0>
• Use Create > Wire name to change wire name(s)

• Use individual wire name from bus to connect to 
single-wire pin 

A<1:0>
B<1:0>



Generate layout from the schematic
From Schematics Menu:
Launch > Layout GXL



From Layout Menu:
Connectivity > Layout GXL

Or click icon in 
bottom left corner:

Select desired metal layer for I/O pins

You can select individual pins if desired



Before module and I/O placement

Blocks initially
outside
prBoundary

This rectangle
is prBoundary

To view block details:  Options > Display form - set display levels “Stop” to 30 



Drag blocks to desired
floorplan locations

“Move” hotkey = m

Note the block 
connections.

These will also be 
highlighted in the 
schematic window.

I/O pins
all in
bottom
corner



After placing modules
To see the nets:    Connectivity > Analyze

Connectivity > Nets > Show/Hide All Incomplete Nets

I/O pins
all in
bottom
corner



Zoom in on lower left corner to view I/O pins
- Select and drag manually to desired boundary edge
- Or auto-place the pins (next slide)



Autoroute pins:
Place > Pin Placement

To place pins on 
specific edges:

Select pins to be placed

Select Edge and Apply

Can place as in 
the schematic

Layout updated automatically – continue changes until happy with arrangement

Change pin 
order on edge



Final pin placement



Power routing between blocks
Draw “Shape” or “Path” to connect power and ground rails of blocks

Mine is not “pretty” since my blocks have pins on M2 close to M2 of power rings!



m1 wire connecting gnd! rings

m2 wires 
connecting
vdd! rings

Example” wires connecting power rings 
(you may choose different wires/layers)

m1 wire connecting gnd! rings



Signal wire routing:
Use the Virtuoso Autorouter

(Virtuoso Space-Based Router)

Route > Automatic Routing

Default values recommended.



Fully-routed circuit block

Run DRC-Extract-LVS

SAVE!!



Block symbol (to connect to I/O pads)

With Schematic Open:  
Create > Cellview > From Cellview

Check and Save



Prepare for full chip layout
 Make a new PadFrame library (so you can edit Frame1_38)
 Attach to UofU_TechLib_ami06
 Select cell Frame1_38 in library UofU_Pads
 Copy it to your PadFrame library (Edit > Copy)
 If you get an error message, click “Fix Errors” and then OK

 Edit your pad frame schematic to change pad_nc instances to 
pad_in or pad_out for your circuit I/O signals
 Decide which pins you wish for circuit I/O signals
 Create a symbol view from the edited schematic

 Create a schematic comprising circuit block and pad frame
 Edit your pad frame layout to match the schematic
 Change pad properties from “pad_nc” to “pad_in” or “pad_out”

 Create chip layout from chip schematic 



Pad frame schematic showing I/O pads
Use the Frame1_38 cell that you copied to your PadFrame library

Schematic:
vdd/gnd placed.
Others pad_nc.



Modify pad frame schematic for your project

 Leave VDD and GND pads 
alone – unless you really 
want them elsewhere.

 Decide which pad to use for 
each I/O pin on your layout 
block.

 Change Cell Names of 
desired signal pads from 
pad_nc to pad_in or pad_out
 Click on pad to select it
 Open properties with hot key 

“q” or right mouse button



• Connect wires and pins on outside of frame, representing external connections

Add wires & pins to 
inside of frame to 
connect to circuit 
block



Pad output pin:

ClearBar output of Pad
will connect to ClearBar
input of the circuit.
It’s OK to leave one of these
unconnected.

Pad input pin:

Pad_ClearBar input to Pad
will connect to external input.

Example:  pad_in (similar arrangement for pad_out)
• DataIn and DataInB connect to circuit
• pad represents wire-bonding connection
• Use related, but different, pin names

(Ex. Pad_ClearBar and    ClearBar)

External Internal



Q<2:0> bundle connects to pad_out inputs.
Add labels <0> <1> etc. to individual wires connected to the pins.

Likewise for Pad_Q<2:0> pad_out output bundle below.

Input pin

To output pin

Check
and
Save



Modify pad frame layout to match schematic
• VDD/GND pads already placed.  Other pads are “pad_nc”.
• Select each desired signal pad, open properties, and change Cell

from pad_nc to pad_in or pad_out.

pad_in

pad_out



Add “pin shapes” to each pad
• Select metal1 in the layer palette
• Zoom in to metal1 next to wire-bond pad
• Menu:  Create > Pin

Enter Terminal Name

Select rectangle

Draw small rectangle
on this metal1& click
to add the pin.

To see pin names:
Options > Display
& check Pin Names



Also add pin shape on metal 2 for connections 
to circuit block. 

• Select metal2 in the layer palette
• Zoom in to metal2 pin on inside of pad frame: DataIn or DataInB or DataOut
• Menu:  Create > Pin   (as on previous slide)

• Make sure you draw your metal2 rectangle within the pin area

Pin name from
circuit side 
of the schematic

DRC and
Save



Create a symbol view of the pad frame 

In the schematic window:
Create > Cell View > From Cellview



Create a new schematic connecting 
circuit block to pad frame

Pad frame                      Circuit Block

Connect pins to pad wire-bond connections

• Check and Save
• Create layout from schematic:  Launch > Layout GXL

Similar to creating block layout from its schematic,
except for I/O pins.  (see next slide)



From Layout Menu:
Connectivity > Layout GXL

Or click icon in 
bottom left corner:

Create chip layout from the chip schematic
• Launch > Layout GXL from the schematic window

UNCHECK
I/O Pins

Select all pad pins,
UNcheck “Create”,
& Apply



Complete the chip layout
• Move pad frame into prBoundary
• Move and position circuit block 

within the pad frame cavity

• Draw VDD/GND wires        
(metal1) from pads to
pad rings of blocks
(make width about 3x 
that of pad ring wires)

• Autoroute signal wires

• DRC/LVS 

• Save vdd

gnd



Placement of frame and core

From 
E. Brunvand
Book



Power/ground routed manually

From 
E. Brunvand
Book



Before signal routing

From 
E. Brunvand
Book



After signal routing

From 
E. Brunvand
Book
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